Brown film on glass

Deltec

ROB6700a

New Member
View Badges
Joined
Jun 4, 2020
Messages
17
Reaction score
49
Soo my tank has been up since early December. And the last 4 days I have this brown/ powder algae on my glass.. I clean it and it will literally be back in an hour, it’s crazy. Should I be concerned. There is no algae really anywhere else.. have a little patch of gha but not much and has been there for awhile..
Tank is at
Nitrates- between 5-15
Phosphate around 0.08
Alk at 9

Started dosing live phyto... maybe I went over bored
 

Ajayabb

Active Member
View Badges
Joined
Mar 16, 2019
Messages
114
Reaction score
101
Sounds like diatoms. Has your lighting schedule changed ? They will pass with times. Do you have a decent cuc ?
 
OP
R

ROB6700a

New Member
View Badges
Joined
Jun 4, 2020
Messages
17
Reaction score
49
Sounds like diatoms. Has your lighting schedule changed ? They will pass with times. Do you have a decent cuc ?
Yea funny u say that, I raised the whites on a part of my schedule a week before this started.. yea I got snails, conch, algae blenny
 

vetteguy53081

Well known Member and monster tank lover
View Badges
Marketplace Rating
Joined
Aug 11, 2013
Messages
45,346
Reaction score
103,665
Location
Wisconsin-Florida in a year
Surface algae with diatoms that is light deficient. Simply use either a magic eraser (original - not scented) or magnetic scraper to remove.
Also add a few astrea, turbo and cerith snails.

1618435020264.png
 
Orphek OR3 reef aquarium LED lighting
AquaNerd
Top