Freshwater issue

TSM Aquatics

Buddha51

New Member
Review score
+0 /0 /-0
View Badges
Joined
Oct 27, 2021
Messages
18
Reaction score
3
Review score
+0 /0 /-0
Location
Alexandria
So I changed my water to 80%. The filter is clean and this is my issue after WC. PLEASE HELP.
13AEF9BF-774B-4C76-B074-ED72711BE2E2.jpeg
 
REEFTIDE

steven m

Community Member
Review score
+0 /0 /-0
View Badges
Joined
Jul 16, 2019
Messages
30
Reaction score
33
Review score
+0 /0 /-0
When I worked in fish stores I use to see people with the same problem. It’s and algae bloom like @Brymac1 stated before. Most commonly caused by running the lights on 24/7. Or for an extended period of time. Most likely the tank is being over fed because koi would eat like they’ve never seen food before. I would recommend getting a canister filter filled with bio media and filter pads, fluval is a good choice and do 25% water changes a week and keep the lights off for most of the day.
 
Fritz
TSM Aquatics

Have you ever torn down a tank over an issue you couldn't seem to beat?

  • Yes! I have. (Tell us about what issue you faced in the thread.)

    Votes: 84 24.4%
  • No. Thankfully, I haven't.

    Votes: 180 52.3%
  • Nope, but it almost happened. (Share your experience in the thread.)

    Votes: 25 7.3%
  • Not yet, but I'm almost there. (Tell us what you're dealing with.)

    Votes: 27 7.8%
  • If you reef long enough, this will eventually happen to you.

    Votes: 24 7.0%
  • Other

    Votes: 4 1.2%
GHL Advanced Technology
Top