Is this Red Ogo OK?

LeftyReefer

Well-Known Member
View Badges
Joined
Jun 17, 2020
Messages
905
Reaction score
943
Review score
+0 /0 /-0
Location
Saginaw
Today I received an order of Red Ogo from BRS/Algaebarn. Fedex delivered it and when I opened it, it had (3) cold packs in the box, but everything was very warm. It came moist, in a jar and the instructions say to rinse it off in fresh saltwater, which I did. When I rinsed it, the rinse bucket did cloud up a bit and lots of bits fell off... I then placed it in my fuge and turned down the lights. I pretty quickly noticed that only a few ends of a few strands are actually red... most of it is brown or green, and a few sections are whitish or clear... Is this likely to recover? or did the high temps during shipping get it?

attached are a few pics of it. You can clearly see what is red and what is green. Not much red unfortunately, but I've never had it before, so maybe this is normal??

20210804_191232.jpg
20210804_191659.jpg
 
Maxout

LuisPerez711

Active Member
View Badges
Joined
Oct 3, 2015
Messages
132
Reaction score
117
Review score
+0 /0 /-0
I received mine the same way. Greenish/brown with some orange. After a couple weeks it started coloring up. I am not sure if it was stressed due to the shipping or lack of light but it did regain its color....then I nuked it and bleached it out haha sorry, I dont have a picture of it colored up.

20210609_135611.jpg
20210609_142129.jpg
 

AlgaeBarn

Marine Aquariums Made Easy!
View Badges
Joined
Oct 14, 2013
Messages
1,860
Reaction score
2,707
Review score
+0 /0 /-0
Location
Denver, Colorado
Today I received an order of Red Ogo from BRS/Algaebarn. Fedex delivered it and when I opened it, it had (3) cold packs in the box, but everything was very warm. It came moist, in a jar and the instructions say to rinse it off in fresh saltwater, which I did. When I rinsed it, the rinse bucket did cloud up a bit and lots of bits fell off... I then placed it in my fuge and turned down the lights. I pretty quickly noticed that only a few ends of a few strands are actually red... most of it is brown or green, and a few sections are whitish or clear... Is this likely to recover? or did the high temps during shipping get it?

attached are a few pics of it. You can clearly see what is red and what is green. Not much red unfortunately, but I've never had it before, so maybe this is normal??

20210804_191232.jpg
20210804_191659.jpg
Hi there! It looks like your red ogo stressed a bit during shipping. Going to send you a DM now to get your order information :)
 

When is the last time you purchased cleanup crew critters?

  • Past few days

    Votes: 58 11.8%
  • Past few weeks

    Votes: 133 27.1%
  • Past few months

    Votes: 158 32.2%
  • Over a half a year

    Votes: 70 14.3%
  • Over a year ago

    Votes: 67 13.7%
  • Other (please explain)

    Votes: 4 0.8%
Ultimate Corals
Top