MAXSPECT GYRE JUMP - maintenance

Ecotech Marine

muffinmanX

New Member
View Badges
Joined
Jun 4, 2021
Messages
24
Reaction score
9
Review score
+0 /0 /-0
Location
malaysia
Hi, i bought the maxspect jump 4k about 9 months ago. havent cleaned it before because i dont see any build ups.

performance seems to be going downwards for the past few weeks (sand wasnt being washed around and cyano build up is visible) and the propeller bladess stopped moving all of the sudden. have cleaned it since then but to no avail. is there something wrong with the motor? it is still moving without the propeller blades but it does seem a bit slow at 90% speed

im not able to take the main propeller at the motor apart... coudlnt find any video online too. pls help. TIA WhatsApp Image 2021-07-19 at 9.46.45 AM.jpeg
 

Attachments

  • WhatsApp Video 2021-07-19 at 9.46.17 AM.mp4
    4.6 MB · Views: 0
Zoanthids

P-Dub

The ocean is open to all, merciful to none.
View Badges
Joined
Sep 30, 2017
Messages
5,155
Reaction score
22,178
Review score
+0 /0 /-0
Location
West Pacific
You're looking at the wrong wear part. The connection on the blades where the shaft runs through rounds out over time. They provide a spare set in the box and sell those replacement pieces because of this
 
OP
M

muffinmanX

New Member
View Badges
Joined
Jun 4, 2021
Messages
24
Reaction score
9
Review score
+0 /0 /-0
Location
malaysia
You're looking at the wrong wear part. The connection on the blades where the shaft runs through rounds out over time. They provide a spare set in the box and sell those replacement pieces because of this
the for the reply. i did change those white bits but to no avail.
is there a way to remove the motor main shaft?

the seller told me to refer to the icecap3k video for the closest reference but im not able to..


was thinking to wash up the main shaft as well
 

P-Dub

The ocean is open to all, merciful to none.
View Badges
Joined
Sep 30, 2017
Messages
5,155
Reaction score
22,178
Review score
+0 /0 /-0
Location
West Pacific
the for the reply. i did change those white bits but to no avail.
is there a way to remove the motor main shaft?

the seller told me to refer to the icecap3k video for the closest reference but im not able to..


was thinking to wash up the main shaft as well
Not the white bits but the black bits. "Plastic Rotor Bushings" seen at exactly 2:01.
 
Orphek OR3 reef aquarium LED lighting

P-Dub

The ocean is open to all, merciful to none.
View Badges
Joined
Sep 30, 2017
Messages
5,155
Reaction score
22,178
Review score
+0 /0 /-0
Location
West Pacific
ok thanks alot. ill order some extras.. and see how it goes.. somehow i dont think the main shaft at th emotor opens up like the icecap 3k...
It doesn't.
There is a like button, btw... ;)
 

dedragon

2500 Club Member
View Badges
Joined
Feb 23, 2019
Messages
2,540
Reaction score
1,988
Review score
+0 /0 /-0
interested in seeing this maintenance tip, receiving the jump 4k tomorrow. Pretty sure it is the exact same pump as the icecap 4k though not sure
 
OP
M

muffinmanX

New Member
View Badges
Joined
Jun 4, 2021
Messages
24
Reaction score
9
Review score
+0 /0 /-0
Location
malaysia
interested in seeing this maintenance tip, receiving the jump 4k tomorrow. Pretty sure it is the exact same pump as the icecap 4k though not sure
ya indeed. dumb manual doesnt say anything. ive got videos from other suppliers that says the left side opens up but have not been able to do so
 

P-Dub

The ocean is open to all, merciful to none.
View Badges
Joined
Sep 30, 2017
Messages
5,155
Reaction score
22,178
Review score
+0 /0 /-0
Location
West Pacific
ya indeed. dumb manual doesnt say anything. ive got videos from other suppliers that says the left side opens up but have not been able to do so
It doesn't open up from either side. Don't try, you might end up breaking the shaft. As far as cleaning, your plan is a good one.
 
Click to watch best scape method in 5 easy steps!

dedragon

2500 Club Member
View Badges
Joined
Feb 23, 2019
Messages
2,540
Reaction score
1,988
Review score
+0 /0 /-0
citric acid does wonders, if its still spinning a bit running it in a citric acid bath might losen up the rest of whatever is blocking it
 
OP
M

muffinmanX

New Member
View Badges
Joined
Jun 4, 2021
Messages
24
Reaction score
9
Review score
+0 /0 /-0
Location
malaysia
also i got the pump today and man its powerful got it running at 30% and still blowing sand on a 3ft tank
mine deteriorated over 9 months without visible calcification and algae build up that may affect its performance.
its no longer blowing sand even at 100%.

maybe an issue with the motorin the first place.. i have cleaned it up with vinegar water solution and will see if everything is ok tomorrow.
 
AI Nero 5

Do you house a "Reef Safe" Angelfish in your reef tank?

  • YES and it's going good

    Votes: 168 41.6%
  • YES but it's not working out

    Votes: 12 3.0%
  • NO I have tried it in the past and it didn't work out

    Votes: 35 8.7%
  • NO I haven't tried yet

    Votes: 175 43.3%
  • Other (please explain)

    Votes: 14 3.5%
Fritz
Top