New DC240 Not Working

Discussion in 'Simplicity Aquatics' started by puffy127, Dec 4, 2017.

  1. puffy127

    puffy127 Active Member

    Joined:
    Feb 2, 2016
    Messages:
    388
    Likes Received:
    242
    Just received a DC240 skimmer and it doesn't turn on. The controller lights initially show full bars then just the first three lights flashing. The pump doesn't turn on. I disassembled the pump and the impeller is cracked in half in two places.

    IMG_20171204_181018[1].jpg

    IMG_20171204_181029[1].jpg
     
    Tags:

  2. puffy127

    puffy127 Active Member

    Joined:
    Feb 2, 2016
    Messages:
    388
    Likes Received:
    242
    I contacted Simplicity on Monday and they responded right away and sent out a new impeller, which I received today. Now breaking in the skimmer. It's amazingly quiet.
     
  3. puffy127

    puffy127 Active Member

    Joined:
    Feb 2, 2016
    Messages:
    388
    Likes Received:
    242
    After only 2 days, on a newly cycled 125 gallon tank:
    IMG_20171211_165629.jpg
     
  4. BobNY

    BobNY Member

    Joined:
    Sep 13, 2011
    Messages:
    35
    Likes Received:
    11
    Location:
    Long Island, NY
    Nice, I recently bought the same skimmer. I haven't installed mine yet. What water level are you running it at?
     
  5. puffy127

    puffy127 Active Member

    Joined:
    Feb 2, 2016
    Messages:
    388
    Likes Received:
    242
    9 inches
     
  6. BobNY

    BobNY Member

    Joined:
    Sep 13, 2011
    Messages:
    35
    Likes Received:
    11
    Location:
    Long Island, NY
    Thanks :)
     
  7. gashunk

    gashunk Active Member

    Joined:
    Sep 8, 2015
    Messages:
    474
    Likes Received:
    209
    I got the 240 as well it’s great I had the pump go out a few months ago and they took care of it right away n it pulls some nasty gunk out
     
Draft saved Draft deleted

Share This Page

Loading...