reef-pi connection problem

tutuss

New Member
View Badges
Joined
Feb 25, 2021
Messages
6
Reaction score
59
Location
france
hello, excuse me in advance for my english. i have a problem. I install reef-pi on a raspberry pi 3+. I use a screen hdmi to see information. I'm connect on localhost with 127.0.0.1. Everything was working well. But after a power cut the raspberry reboot and i'm impossible to reconnect at reef-pi.
I tried 'sudo systemctl status reef-pi.service' but reef-pi is active. ato run but i can't see something.
I tried 'http://localhost ' don't work
chromium say " this site is inaccessible 127.0.0.1 does not allow connection"
i'm thinking of a bug to reef-pi or raspberry
i need help
thank you in advance
 
Budmans

Ranjib

7500 Club Member
View Badges
Joined
Apr 16, 2016
Messages
8,667
Reaction score
15,176
Location
Palo Alto, Bay Area
Can you run ‘sudo systemctl restart reef-pi.service’ and see if t resolves. Check the logs for errors and share it here if the problem persist
 
OP
T

tutuss

New Member
View Badges
Joined
Feb 25, 2021
Messages
6
Reaction score
59
Location
france
hi, thanks for your attention
i run 'sudo systemctl restart reef-pi.service' but nothing change. i re-install reef-pi with release but no change.


[email protected]:~ $ sudo systemctl status reef-pi.service
● reef-pi.service - raspberry pi based reef tank controller
Loaded: loaded (/lib/systemd/system/reef-pi.service; enabled; vendor prese
Active: active (running) since Thu 2021-02-25 18:09:32 CET; 9min ago
Main PID: 369 (reef-pi)
Tasks: 13 (limit: 2062)
CGroup: /system.slice/reef-pi.service
└─369 /usr/bin/reef-pi daemon -config /etc/reef-pi/config.yaml

févr. 25 18:18:54 reef-pi reef-pi[369]: 2021/02/25 18:18:54 onTime 0 offTim
févr. 25 18:18:54 reef-pi reef-pi[369]: 2021/02/25 18:18:54 ato-subsystem: se
févr. 25 18:18:55 reef-pi reef-pi[369]: 2021/02/25 18:18:55 ato-subsystem: se
févr. 25 18:18:55 reef-pi reef-pi[369]: 2021/02/25 18:18:55 Euipment: 2 On: f
févr. 25 18:18:55 reef-pi reef-pi[369]: 2021/02/25 18:18:55 onTime 0 offTim
févr. 25 18:18:55 reef-pi reef-pi[369]: 2021/02/25 18:18:55 ato-subsystem: se
févr. 25 18:18:56 reef-pi reef-pi[369]: 2021/02/25 18:18:56 ato-subsystem: se
févr. 25 18:18:56 reef-pi reef-pi[369]: 2021/02/25 18:18:56 Euipment: 2 On: f
févr. 25 18:18:56 reef-pi reef-pi[369]: 2021/02/25 18:18:56 onTime 0 offTim
févr. 25 18:18:56 reef-pi reef-pi[369]: 2021/02/25 18:18:56 ato-subsystem: se
lines 1-18/18 (END)


about journal

[email protected]:~ $ sudo journalctl -fu reef-pi.service
-- Logs begin at Thu 2019-02-14 11:11:59 CET. --
févr. 25 18:24:49 reef-pi reef-pi[369]: 2021/02/25 18:24:49 onTime 0 offTime 4096
févr. 25 18:24:49 reef-pi reef-pi[369]: 2021/02/25 18:24:49 ato-subsystem: sensor: flotteur usage: 4
févr. 25 18:24:50 reef-pi reef-pi[369]: 2021/02/25 18:24:50 ato-subsystem: sensor: flotteur state: 1
févr. 25 18:24:50 reef-pi reef-pi[369]: 2021/02/25 18:24:50 Euipment: 2 On: false
févr. 25 18:24:50 reef-pi reef-pi[369]: 2021/02/25 18:24:50 onTime 0 offTime 4096
févr. 25 18:24:50 reef-pi reef-pi[369]: 2021/02/25 18:24:50 ato-subsystem: sensor: flotteur usage: 4
févr. 25 18:24:51 reef-pi reef-pi[369]: 2021/02/25 18:24:51 ato-subsystem: sensor: flotteur state: 1
févr. 25 18:24:51 reef-pi reef-pi[369]: 2021/02/25 18:24:51 Euipment: 2 On: false
i don't understand
 

Ranjib

7500 Club Member
View Badges
Joined
Apr 16, 2016
Messages
8,667
Reaction score
15,176
Location
Palo Alto, Bay Area
hi, thanks for your attention
i run 'sudo systemctl restart reef-pi.service' but nothing change. i re-install reef-pi with release but no change.


[email protected]:~ $ sudo systemctl status reef-pi.service
● reef-pi.service - raspberry pi based reef tank controller
Loaded: loaded (/lib/systemd/system/reef-pi.service; enabled; vendor prese
Active: active (running) since Thu 2021-02-25 18:09:32 CET; 9min ago
Main PID: 369 (reef-pi)
Tasks: 13 (limit: 2062)
CGroup: /system.slice/reef-pi.service
└─369 /usr/bin/reef-pi daemon -config /etc/reef-pi/config.yaml

févr. 25 18:18:54 reef-pi reef-pi[369]: 2021/02/25 18:18:54 onTime 0 offTim
févr. 25 18:18:54 reef-pi reef-pi[369]: 2021/02/25 18:18:54 ato-subsystem: se
févr. 25 18:18:55 reef-pi reef-pi[369]: 2021/02/25 18:18:55 ato-subsystem: se
févr. 25 18:18:55 reef-pi reef-pi[369]: 2021/02/25 18:18:55 Euipment: 2 On: f
févr. 25 18:18:55 reef-pi reef-pi[369]: 2021/02/25 18:18:55 onTime 0 offTim
févr. 25 18:18:55 reef-pi reef-pi[369]: 2021/02/25 18:18:55 ato-subsystem: se
févr. 25 18:18:56 reef-pi reef-pi[369]: 2021/02/25 18:18:56 ato-subsystem: se
févr. 25 18:18:56 reef-pi reef-pi[369]: 2021/02/25 18:18:56 Euipment: 2 On: f
févr. 25 18:18:56 reef-pi reef-pi[369]: 2021/02/25 18:18:56 onTime 0 offTim
févr. 25 18:18:56 reef-pi reef-pi[369]: 2021/02/25 18:18:56 ato-subsystem: se
lines 1-18/18 (END)


about journal

[email protected]:~ $ sudo journalctl -fu reef-pi.service
-- Logs begin at Thu 2019-02-14 11:11:59 CET. --
févr. 25 18:24:49 reef-pi reef-pi[369]: 2021/02/25 18:24:49 onTime 0 offTime 4096
févr. 25 18:24:49 reef-pi reef-pi[369]: 2021/02/25 18:24:49 ato-subsystem: sensor: flotteur usage: 4
févr. 25 18:24:50 reef-pi reef-pi[369]: 2021/02/25 18:24:50 ato-subsystem: sensor: flotteur state: 1
févr. 25 18:24:50 reef-pi reef-pi[369]: 2021/02/25 18:24:50 Euipment: 2 On: false
févr. 25 18:24:50 reef-pi reef-pi[369]: 2021/02/25 18:24:50 onTime 0 offTime 4096
févr. 25 18:24:50 reef-pi reef-pi[369]: 2021/02/25 18:24:50 ato-subsystem: sensor: flotteur usage: 4
févr. 25 18:24:51 reef-pi reef-pi[369]: 2021/02/25 18:24:51 ato-subsystem: sensor: flotteur state: 1
févr. 25 18:24:51 reef-pi reef-pi[369]: 2021/02/25 18:24:51 Euipment: 2 On: false
i don't understand
It means reef-pi is running (Active: active (running)). Looks like your controller is running ato at 1 second check interval, with pca9685 driver (0-4096 ). You should be able to access the web ui. Can you run
Code:
sudo netstat -tulnp
and share the output? This will show all the ports that are in use, and reef-pi should come up with port 80
 
OP
T

tutuss

New Member
View Badges
Joined
Feb 25, 2021
Messages
6
Reaction score
59
Location
france
hello !
[email protected]:~ $ sudo netstat -tulnp
Connexions Internet actives (seulement serveurs)
Proto Recv-Q Send-Q Adresse locale Adresse distante Etat PID/Program name
tcp 0 0 0.0.0.0:5900 0.0.0.0:* LISTEN 2538/vncserver-x11-
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 502/sshd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 15794/cupsd
tcp6 0 0 :::5900 :::* LISTEN 2538/vncserver-x11-
tcp6 0 0 :::22 :::* LISTEN 502/sshd
tcp6 0 0 ::1:631 :::* LISTEN 15794/cupsd
udp 0 0 0.0.0.0:68 0.0.0.0:* 451/dhcpcd
udp 0 0 0.0.0.0:631 0.0.0.0:* 15795/cups-browsed
udp 0 0 0.0.0.0:42125 0.0.0.0:* 389/avahi-daemon: r
udp 0 0 0.0.0.0:5353 0.0.0.0:* 389/avahi-daemon: r
udp6 0 0 :::41122 :::* 389/avahi-daemon: r
udp6 0 0 :::5353 :::* 389/avahi-daemon: r

Sorry, i'm not a specialist to servers
I can't connect on localhost and by wifi. The address on browser say 'unable to open page'
I think of a bug of raspberry
 
Budmans
OP
T

tutuss

New Member
View Badges
Joined
Feb 25, 2021
Messages
6
Reaction score
59
Location
france
Hi! I re-install all. (Raspberry and reef-pi) an it works again. I have access to reef-pi at distance and localhost. I don’t understand where are problems. I hope it won’t start again.
 

RJDaPirate

New Member
View Badges
Joined
Feb 19, 2021
Messages
4
Reaction score
2
Location
Savage
I have also been experiencing the same issue. My Reef Pi is still on the workbench as I add components. Whenever I need to power it off I have to repull and run the github install files. I should have mentioned I am running version 4.1.
 
Last edited:

Ranjib

7500 Club Member
View Badges
Joined
Apr 16, 2016
Messages
8,667
Reaction score
15,176
Location
Palo Alto, Bay Area
hello !
[email protected]:~ $ sudo netstat -tulnp
Connexions Internet actives (seulement serveurs)
Proto Recv-Q Send-Q Adresse locale Adresse distante Etat PID/Program name
tcp 0 0 0.0.0.0:5900 0.0.0.0:* LISTEN 2538/vncserver-x11-
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 502/sshd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 15794/cupsd
tcp6 0 0 :::5900 :::* LISTEN 2538/vncserver-x11-
tcp6 0 0 :::22 :::* LISTEN 502/sshd
tcp6 0 0 ::1:631 :::* LISTEN 15794/cupsd
udp 0 0 0.0.0.0:68 0.0.0.0:* 451/dhcpcd
udp 0 0 0.0.0.0:631 0.0.0.0:* 15795/cups-browsed
udp 0 0 0.0.0.0:42125 0.0.0.0:* 389/avahi-daemon: r
udp 0 0 0.0.0.0:5353 0.0.0.0:* 389/avahi-daemon: r
udp6 0 0 :::41122 :::* 389/avahi-daemon: r
udp6 0 0 :::5353 :::* 389/avahi-daemon: r

Sorry, i'm not a specialist to servers
I can't connect on localhost and by wifi. The address on browser say 'unable to open page'
I think of a bug of raspberry
I don't see reef-pi in this list. This is a problem. I don't know what's causing this, reef-pi is not listening in port 80, i,e. the Web UI part of reef-pi is not working. Only the controller is running.
 

Ranjib

7500 Club Member
View Badges
Joined
Apr 16, 2016
Messages
8,667
Reaction score
15,176
Location
Palo Alto, Bay Area
I have also been experiencing the same issue. My Reef Pi is still on the workbench as I add components. Whenever I need to power it off I have to repull and run the github install files. I should have mentioned I am running version 4.1.
Start a thread if you want to debug this. I would love to assist. But not in this thread.
 

BIG TANKS VERSUS SMALLER TANKS...WHICH DO YOU PREFER?

  • BIGGER

    Votes: 631 75.8%
  • smaller

    Votes: 157 18.9%
  • Other (please explain)

    Votes: 44 5.3%

Online statistics

Members online
770
Guests online
3,242
Total visitors
4,012
MAX OUT
Top