Verifying any recent issues with Orphek Atlantik V4 upgrading with the iCon connect package without the LED board

evoIX_njreefer

Active Member
Review score
+1 /0 /-0
View Badges
Joined
Jan 28, 2010
Messages
122
Reaction score
76
Review score
+1 /0 /-0
Location
New Milford, NJ
I just installed the iCon kit without the LED board. I wanted a better app and easier connection. I had time this passed weekend and found that I now have multiple (2 at the moment) LEDs flickering.

I, unfortunately, do not have any recent videos of the tank to show this wasn't an issue. So trying to find if there is multiple individuals experiencing this issue.

I know the likelihood is small so we'll see how support responds and if any other Orphek user has any other experiences with this.

Thank you,
Mike
 
OP
E

evoIX_njreefer

Active Member
Review score
+1 /0 /-0
View Badges
Joined
Jan 28, 2010
Messages
122
Reaction score
76
Review score
+1 /0 /-0
Location
New Milford, NJ
Here is the response:

Dear Mike,

Thank you for your email.

The iCon pc card works no problem with the v4 led board or we won't offer the upgrade.
Many clients did upgrade and have no problem :)

Please let us know which two leds flicker.
It's better if you can send us video showing the issue.


The two LED lights are now dead and no longer even flickering.

So maybe it was time for them to go just coincidence. Not going to blame them for it or the kit. Shii happens. I just want it down in case this becomes a common issue or others start experiencing the issue, we know of a possible bigger issue that needs to be addressed.

Hopefully only those two will have issues. So far all others are working fine.
 

gatorbait01

Active Member
Review score
+0 /0 /-0
View Badges
Joined
Jul 21, 2017
Messages
189
Reaction score
108
Review score
+0 /0 /-0
I have a non-upgraded v4 fuxture and at one time I had a couple LEDs that were flickering. They sent me some new LEDs to replace them, but they stopped flickering when I checked a few days later and never replaced them. It's been a couple years and I hadn't checked them recently. Apart from that, how do you like the upgraded pcb? It would be a nice to have, but not sure if it's worthwhile.

 

Have you ever torn down a tank over an issue you couldn't seem to beat?

  • Yes! I have. (Tell us about what issue you faced in the thread.)

    Votes: 178 24.3%
  • No. Thankfully, I haven't.

    Votes: 377 51.5%
  • Nope, but it almost happened. (Share your experience in the thread.)

    Votes: 55 7.5%
  • Not yet, but I'm almost there. (Tell us what you're dealing with.)

    Votes: 61 8.3%
  • If you reef long enough, this will eventually happen to you.

    Votes: 47 6.4%
  • Other

    Votes: 14 1.9%
Top