Brand new Gen5 Radion lights BROKEN LED!?

Ecotech Marine

MoH

Active Member
View Badges
Joined
Dec 9, 2017
Messages
216
Reaction score
193
Hello guys,

So I just purchased a brand new Radion XR15 Blue Gen5 from a local reefer. The package was still sealed and unopened. I just opened the box and plugged in the light and to my surprise as I flipped through the channels on mobious and counted all the leds 5 of the royal blue leds do not work! Only 15 of them light up and the box shows that 20 royal blue leds. Is this some type of settings issue? Am I doing something wrong to test if all is working? Do the 5 leds there not work for a reason? Light has all the latest update etc. Anyone else receive broken Gen5 lights? I’m shocked by this as I’m eco tech all the way I have Radion gen 4s mp40s vectra pumps and battery backup. Strong supporter and always found the quality of their products top of the line.

D841D4BA-A9CA-4CED-B77A-E9D74CCAC060.jpeg A901482C-AEAF-4FA9-9EA7-A780F09C82EE.jpeg
 
Top Shelf Aquatics
OP
M

MoH

Active Member
View Badges
Joined
Dec 9, 2017
Messages
216
Reaction score
193
Adding - I did open a support ticket and the local reefer is sending me the invoice proof of purchase. Forsure this is brand new.

What do you guys think? I surely would not expect quality control issues like this from ecotech. These things are not cheap!!!
 
OP
M

MoH

Active Member
View Badges
Joined
Dec 9, 2017
Messages
216
Reaction score
193
UPDATE - So surprisingly to me Ecotech will not support this issue to me since I am not the original purchaser and the warranty can not be used. How unbelievable is that! This product is brand new and the light has not been out for even a year! I’m shocked at the level of service. I’m a big time fan of ecotech and strong supporter never expected that from them. Now I have to get the person who I bought the light from to open and submit a ticket since he was the original buyer of the light. What a run around for something that should just work and is suppose to be the highest of quality.
 

Are you currently running a reactor and media on your reef tank?

  • Yes (please tell us what in the thread)

    Votes: 94 40.5%
  • NO but I run media from time to time

    Votes: 66 28.4%
  • NO I don't use filter media

    Votes: 67 28.9%
  • Other (please explain)

    Votes: 5 2.2%

Online statistics

Members online
2,241
Guests online
6,235
Total visitors
8,476
Zooxae - Great Products / Prices / Service
Top