Red Sea Max E 170 Circulation Pump Not Turning On

Amanda Boda

New Member
View Badges
Joined
May 13, 2024
Messages
11
Reaction score
31
Location
Coronado
Rating - 0%
0   0   0
I just set up and filled a Red Sea MAX e 170 and went to turn on the circulation pump and it is not turning on. I tried contacting their customer support but it is after hours.

My lights, heater and skimmer all work, so there isn't an issue with my power supply. I don't know how to troubleshoot this or if there is anything I can do. This is my first tank.
 

DaJMasta

Well-Known Member
View Badges
Joined
Feb 3, 2022
Messages
826
Reaction score
940
Location
Maryland
Rating - 0%
0   0   0
Have you tried a different plug for the pump? Have you tried pulling the pump out of the back to see if there's something visibly wrong with it? Have you tried disassembling the pump?

While it's a "custom" part for Red Sea by Sicce, it's a Sicce Syncra Silent 1.5 or 2.0 (don't remember). There should be plenty of information as to making sure it's installed, serviced, etc., but if you're plugging it in, submerging it, and it's not turning on - your best bet is probably just having it replaced through your vendor.
 

Baronen

Active Member
View Badges
Joined
Apr 26, 2020
Messages
326
Reaction score
120
Rating - 0%
0   0   0
Try turning it off and on a bunch and waiting a few seconds. I have a Red Sea pump that is difficult to turn back on after water changes but it always does eventually
 
OP
OP
Amanda Boda

Amanda Boda

New Member
View Badges
Joined
May 13, 2024
Messages
11
Reaction score
31
Location
Coronado
Rating - 0%
0   0   0
Have you tried a different plug for the pump? Have you tried pulling the pump out of the back to see if there's something visibly wrong with it? Have you tried disassembling the pump?

While it's a "custom" part for Red Sea by Sicce, it's a Sicce Syncra Silent 1.5 or 2.0 (don't remember). There should be plenty of information as to making sure it's installed, serviced, etc., but if you're plugging it in, submerging it, and it's not turning on - your best bet is probably just having it replaced through your vendor.
After doing all of your recommendations, I'm happy to report that it turned on and is in working order! Thank you very much for your advice and insight. I took it apart and put it back together, and that seemed to do the trick. Thank you again!
 

How much do you care about having a display FREE of wires, pumps and equipment?

  • Want it squeaky clean! Wires be danged!

    Votes: 13 41.9%
  • A few things are ok with me!

    Votes: 16 51.6%
  • No care at all! Bring it on!

    Votes: 2 6.5%
Back
Top