Totally lost with reef-pi install


Community Member
Review score
+0 /0 /-0
View Badges
Dec 23, 2015
Reaction score
Review score
+0 /0 /-0
I am setting up my reef-pi system purchased through robo-tank and I am at a total standstill and would appreciate some help. I am installing from a Mac and using terminal instead of Putty. I thought I had it figured out but apparently I have gone wrong somewhere and can't get back on track. I successfully installed the OS and connected via SSH through the Mac terminal. I ran the install and it told me reef-pi was successfully installed. I got this message:

You have successfully installed reef-pi, you can now press ENTER on your keyboard to

restart your Raspberry Pi.

After the Raspberry Pi restarts open a web browser from any device on your local

network and type one of the links below. The first link is the IP address of the

Raspberry Pi, the 2nd link is the hostname you added during the installation. Write

these down or create a bookmark in your browser. Note it is possible your network

changes the IP address for the Raspberry Pi and the link no longer works, this is

why we setup a hostname as this will never change.

http://sudo systemctl status reef-pi.service

The default login for reef-pi is as follows.

Username = reef-pi

Password = reef-pi

Have a great day!

Press ENTER on your keyboard to restart the Raspberry Pi.

I was pretty pleased with myself because despite considering myself above average in computer literacy, I don't really have any experience with this kind of stuff. So I pressed enter and...

sudo: unable to resolve host raspberrypi: Name or service not known

Connection to closed by remote host.

Connection to closed.

Ok, maybe this was what it was supposed to say? So I waited a minute or two and attempted to log in to the reef-pi on the browser.... unable to connect to server. I did some searching and found this command line that is supposed to check the status of reef pi...

sudo systemctl status reef-pi.service

And this was what the terminal spit out:

-bash: http://sudo: No such file or directory

I have no idea where to go from here. I feel kind of ignorant and I'm hoping that I did not make a mistake in going with the reef-pi if this is the level of technical skill involved in order to configure and run the program. Hoping someone can guide me to a resolution here. Will try to keep up with this thread as quickly as possible if more info is needed to move forward. Thanks!
World Wide Corals
Top Shelf Aquatics


Well-Known Member
Review score
+0 /0 /-0
View Badges
Feb 14, 2020
Reaction score
Review score
+0 /0 /-0
Edmonton, Canada
Sorry for the long delay I was away for the long weekend. Glad you got this solved, I think you're right about not using a hostname might have been an issue as it printed this line out.

http://sudo systemctl status reef-pi.service

That was suppose to be a link to the hostname and looks like maybe it was still set with that which might have caused issues, thanks for pointing it out.

How have you used eggcrate in or around your aquarium?

  • Aquarium lid

    Votes: 38 38.8%
  • Frag rack

    Votes: 52 53.1%
  • Skimmer stand

    Votes: 31 31.6%
  • Sump Divider

    Votes: 25 25.5%
  • Other (please describe in the discussion)

    Votes: 15 15.3%
  • I have not used eggcrate in or around my aquarium

    Votes: 22 22.4%
RAP Texas