Connection problems Jecod / Jebao, despair.

Jonas Damien

New Member
View Badges
Joined
Jan 12, 2024
Messages
10
Reaction score
65
Location
Bruges Belgium
Rating - 0%
0   0   0
Hello everyone,

Hopefully there are some IT specialists here too. Already skimmed many forums (including this one) and tried all the tips. My apologies but this is going to be a long text.

I have 5 pumps all of which should be able to work with either wifi network or access point:
Jebao MDC-3500 booster pump
Jebao MDC-6000 booster pump
2x Jecod ALW-20 wave maker
Jebao MD-4.4 Doser pump

I bought the 2 booster pumps first. With this, the installation was still with the old app and was able to connect smoothly to my home network via my mobile phone (Samsung A52). In doing so, I used the wifi of my internet provider's modem/router.

Since this went so well, I bought the 2 wave makers as well as the doser pump.
However, with none of these pumps could I establish a connection to my ISP's modem/router. Tried further from the modem, tried near the modem, all to no avail. The direct access point (AP) between wave makers and my smartphone did succeed.

I then split the 2.4GHz and 5GHz signals in my modem's settings and disabled the 5GHz signal completely. Tried again to connect to the pump on my home network (again near and further away from the modem), however, to no avail.

I then installed the app on several android devices (Smartphone Partner, Smartphone eldest daughter, own tablet, tablet eldest daughter, tablet youngest daughter). On my youngest daughter's tablet, I was then able to connect to the wave makers via my wifi home network.

Since the wifi network was not so fantastically good anyway, I made the decision to build a mesh network. Note here that my provider or other providers in my country do not really give the option in free modem/router choice. A law to allow this has been passed and will apply on 01 November 2024.
What can be done is to place a 2 router after the provider's modem/router.
My choice is the TP-Link mesh ax3000 poe mesh wifi (deco x50-poe).
This mainly for the 6GHz and the poe (power over Ethernet).
The configuration of my network is as follows;
Modem router from the provider - Master mesh TP-link X50 - TP-Link switch with poe (model TL-SG2428P) - 3 x slave mesh TP-link X50 (each on their own port directly on the switch, so no through connections)
The router/modem, master TP-Link X50 and switch are on the 1st floor (ground floor) of the main building. The 3 slave mesh TP-Link X50 are on the 2nd floor (1st floor in Europe) of the main building, the 3rd floor (2nd floor in Europe) of the main building and the 2nd floor (1st floor in Europe) of the annex.
Disabled the wifi from the internet provider's Modem/router to avoid interference. This all works perfectly, I now have perfect wifi coverage everywhere in the house.

After reinstalling the new home network, tried again to connect to the wave makers on my wifi home network, again to no avail. Note here that the Jebao Aqua app had since been updated.

Disabled the 5GHz signal from the Mesh TP-Link X50, again with no result.

Also gave my Smartphone the update from Android 13 to 14 and tested again, with no result.

Put the wave makers in AP mode and checked if it was visible, using a wifi analyser (shows all available wifi networks in your area), which it was. To clarify, the pump in wifi mode is receiving and thus not visible as a wifi signal, the pump in AP mode is transmitting and thus visible as a wifi signal. The below image shows the channels of the Jeboa (0-3), my wifi network (4-8) and my smartphone (9-13). The channels of the TP-Link Mesh cannot be set. Also, the channels of the Jebao are these from which it transmits, I don't know if it can receive over the full channel width.
WIFI analyzer.jpeg



Took out my youngest daughter's tablet again (which did connect on the old network with the old app), it had also received the update Jeboa App by now. Tested to connect and this no longer works.

I then turned my partner's smartphone into an AP (in which case the smartphone turned into a router). Connected my smartphone to it and tried again to connect to the wave maker via the wifi network (of my partner's smartphone). This succeeded strangely enough.

Turned my Windows 10 Laptop into an AP and tried to connect again. At first, it failed to establish a wifi connection with the wave maker.
I had read somewhere that you need to allow location authorisation of the Jebao app, in the app settings of android. Allowed this and again tried to establish a wifi connection to the wave maker via my laptop's AP network. This worked again.

Then I had the idea, if I could run the app on my windows PC, which has a lan connection and a wifi connection to my home network, maybe I could establish a connection this way. Installed an Android emulator BleuStacks, then installed the Jeboa Aqua app on Bleustacks and then started the app. However, the app crashes during startup. No matter what I try, the app won't run. So again, no solution.

Using a USB-C Ethernet adapter, I made a direct LAN connection on the switch to my smartphone. To do this, however, I first had to disable the wifi and mobile network on my smartphone. Once this lan connection was established (tested using the browser, among others), I switched the smartphone's wifi back on. In the settings of the mesh TP-Link X50, checked whether a connection was visible via both wifi and LAN from my smartphone, which was the case. Restarted the Jebao Aqua app and tried to connect, strangely, the app indicated that no wifi network was detected and so I couldn't connect to a pump. So probably the smartphone prioritises a LAN connection over a wifi connection. The moment I physically disconnected the LAN connection, the wifi network was immediately visible in the app. I then tried, at the start of scanning for a pump, to immediately reconnect the lan connection. However again without result.

To check everything again, I tried connecting all 5 pumps to my home network again, with no result. In fact, I suddenly can't even make an AP connection with both feed pumps since installing the new app. I can make an ap wifi connection between my smartphone and the booster pumps, I can see the booster pumps' wifi signal with a wifi analyser but it doesn't manage to pair the pumps in the app. It keeps searching for the pumps.


As you can see, I have already tried a lot with limited IT knowledge.

These 5 pumps have cost a pretty penny and none of them has effective running hours in an aquarium yet. Had I known all this in advance I definitely would not have bought these. Hereby, if there are other people who would be interested in buying wifi pumps from Jeboa/Jecod, DON'T DO IT!

Meanwhile, I must try to carry on with this series and beg everyone if they don't know a solution.


Thanks in advance for the reactions,
Regards, JD
 

KrisReef

10K Club member
View Badges
Joined
May 15, 2018
Messages
14,022
Reaction score
29,218
Location
ADX Florence
Rating - 0%
0   0   0
Hello everyone,

Hopefully there are some IT specialists here too. Already skimmed many forums (including this one) and tried all the tips. My apologies but this is going to be a long text.

I have 5 pumps all of which should be able to work with either wifi network or access point:
Jebao MDC-3500 booster pump
Jebao MDC-6000 booster pump
2x Jecod ALW-20 wave maker
Jebao MD-4.4 Doser pump

I bought the 2 booster pumps first. With this, the installation was still with the old app and was able to connect smoothly to my home network via my mobile phone (Samsung A52). In doing so, I used the wifi of my internet provider's modem/router.

Since this went so well, I bought the 2 wave makers as well as the doser pump.
However, with none of these pumps could I establish a connection to my ISP's modem/router. Tried further from the modem, tried near the modem, all to no avail. The direct access point (AP) between wave makers and my smartphone did succeed.

I then split the 2.4GHz and 5GHz signals in my modem's settings and disabled the 5GHz signal completely. Tried again to connect to the pump on my home network (again near and further away from the modem), however, to no avail.

I then installed the app on several android devices (Smartphone Partner, Smartphone eldest daughter, own tablet, tablet eldest daughter, tablet youngest daughter). On my youngest daughter's tablet, I was then able to connect to the wave makers via my wifi home network.

Since the wifi network was not so fantastically good anyway, I made the decision to build a mesh network. Note here that my provider or other providers in my country do not really give the option in free modem/router choice. A law to allow this has been passed and will apply on 01 November 2024.
What can be done is to place a 2 router after the provider's modem/router.
My choice is the TP-Link mesh ax3000 poe mesh wifi (deco x50-poe).
This mainly for the 6GHz and the poe (power over Ethernet).
The configuration of my network is as follows;
Modem router from the provider - Master mesh TP-link X50 - TP-Link switch with poe (model TL-SG2428P) - 3 x slave mesh TP-link X50 (each on their own port directly on the switch, so no through connections)
The router/modem, master TP-Link X50 and switch are on the 1st floor (ground floor) of the main building. The 3 slave mesh TP-Link X50 are on the 2nd floor (1st floor in Europe) of the main building, the 3rd floor (2nd floor in Europe) of the main building and the 2nd floor (1st floor in Europe) of the annex.
Disabled the wifi from the internet provider's Modem/router to avoid interference. This all works perfectly, I now have perfect wifi coverage everywhere in the house.

After reinstalling the new home network, tried again to connect to the wave makers on my wifi home network, again to no avail. Note here that the Jebao Aqua app had since been updated.

Disabled the 5GHz signal from the Mesh TP-Link X50, again with no result.

Also gave my Smartphone the update from Android 13 to 14 and tested again, with no result.

Put the wave makers in AP mode and checked if it was visible, using a wifi analyser (shows all available wifi networks in your area), which it was. To clarify, the pump in wifi mode is receiving and thus not visible as a wifi signal, the pump in AP mode is transmitting and thus visible as a wifi signal. The below image shows the channels of the Jeboa (0-3), my wifi network (4-8) and my smartphone (9-13). The channels of the TP-Link Mesh cannot be set. Also, the channels of the Jebao are these from which it transmits, I don't know if it can receive over the full channel width.
WIFI analyzer.jpeg



Took out my youngest daughter's tablet again (which did connect on the old network with the old app), it had also received the update Jeboa App by now. Tested to connect and this no longer works.

I then turned my partner's smartphone into an AP (in which case the smartphone turned into a router). Connected my smartphone to it and tried again to connect to the wave maker via the wifi network (of my partner's smartphone). This succeeded strangely enough.

Turned my Windows 10 Laptop into an AP and tried to connect again. At first, it failed to establish a wifi connection with the wave maker.
I had read somewhere that you need to allow location authorisation of the Jebao app, in the app settings of android. Allowed this and again tried to establish a wifi connection to the wave maker via my laptop's AP network. This worked again.

Then I had the idea, if I could run the app on my windows PC, which has a lan connection and a wifi connection to my home network, maybe I could establish a connection this way. Installed an Android emulator BleuStacks, then installed the Jeboa Aqua app on Bleustacks and then started the app. However, the app crashes during startup. No matter what I try, the app won't run. So again, no solution.

Using a USB-C Ethernet adapter, I made a direct LAN connection on the switch to my smartphone. To do this, however, I first had to disable the wifi and mobile network on my smartphone. Once this lan connection was established (tested using the browser, among others), I switched the smartphone's wifi back on. In the settings of the mesh TP-Link X50, checked whether a connection was visible via both wifi and LAN from my smartphone, which was the case. Restarted the Jebao Aqua app and tried to connect, strangely, the app indicated that no wifi network was detected and so I couldn't connect to a pump. So probably the smartphone prioritises a LAN connection over a wifi connection. The moment I physically disconnected the LAN connection, the wifi network was immediately visible in the app. I then tried, at the start of scanning for a pump, to immediately reconnect the lan connection. However again without result.

To check everything again, I tried connecting all 5 pumps to my home network again, with no result. In fact, I suddenly can't even make an AP connection with both feed pumps since installing the new app. I can make an ap wifi connection between my smartphone and the booster pumps, I can see the booster pumps' wifi signal with a wifi analyser but it doesn't manage to pair the pumps in the app. It keeps searching for the pumps.


As you can see, I have already tried a lot with limited IT knowledge.

These 5 pumps have cost a pretty penny and none of them has effective running hours in an aquarium yet. Had I known all this in advance I definitely would not have bought these. Hereby, if there are other people who would be interested in buying wifi pumps from Jeboa/Jecod, DON'T DO IT!

Meanwhile, I must try to carry on with this series and beg everyone if they don't know a solution.


Thanks in advance for the reactions,
Regards, JD
yes, it is visible. The length is challenging for many people to get started reading, perhaps?

I don't have this hardware so I can't be helpful either.

Bump
 

Henk

Community Member
View Badges
Joined
Sep 8, 2018
Messages
72
Reaction score
137
Rating - 0%
0   0   0
Sounds complicated. Did you try contacting their customer service? I have not used their wifi wavemakers, but I used their other wavemakers and never got more than 2 years out of these pumps. Their return pumps are excellent though.
 

tharbin

2500 Club Member
View Badges
Joined
Oct 22, 2021
Messages
4,893
Reaction score
33,848
Location
Arizona
Rating - 0%
0   0   0
I don't have any of this equipment so I can't help much but I can tell you that, unless your jecod/jebao equipment has wired connectors, do not waste your time trying to mix WiFi and wired connections. Most equipment will internally turn off WiFi when it senses a wired connection. The vast majority of devices can only communicate on one network channel at a time.

I had a hard time following your sequence through to its present state so I don't know for sure what the present status is but:

-Set up an SSID for 2.4 only access. Do not use the same SSID as used for your 5/6 networks. You need to ensure the devices don't band hop.

-If your 2.4 is vlaned, temporarily turn off any restrictions between that vlan and your native lan

-Put all of the pumps back to their default setup and rejoin them to the 2.4 only network.

-Take one smart device and have it connect to that network and hopefully you will be able to finish setup

-If the 2.4 is vlaned, one by one turn on your firewall rules and test after each one.

Hope this helps. Basically, you have done so much that I feel you need a hard reset and restart to make sure all of the devices are talking to the same SSID at the same time and that the SSID is only for 2.4 access. That said, it seems that there could also be an issue with the latest app update.
 
OP
OP
Jonas Damien

Jonas Damien

New Member
View Badges
Joined
Jan 12, 2024
Messages
10
Reaction score
65
Location
Bruges Belgium
Rating - 0%
0   0   0
I solved it. The way is not so kosher but hey, it works. I turned the modem/router's WiFi back on, only on 2.4 Ghz. This now runs simultaneously with the WiFi of my mesh network. I know that router after router is not recommended, but for my application it is not a problem. The modem/router 2.4Ghz is set to channel 1. The pumps also work on channel 1 in AP, so I am almost certain that they will also work on channel 1 in WiFi mode. I then added the MAC addresses of the pumps to the modem/router. Finally, and this is probably the cause of the connection problems, I set the modem/router's security protocol to WPA2-PSK. This gives me a connection to the pumps. I checked which protocol my mesh network was on and the default is WPA2-PSK, but I cannot connect to this. Since I cannot set the channels of the mesh, I suspect that the problem lies there somewhere. Still, thanks for thinking along.
 

Jody Owens

Active Member
View Badges
Joined
Aug 11, 2023
Messages
152
Reaction score
44
Location
Kansas City
Rating - 100%
2   0   0
I solved it. The way is not so kosher but hey, it works. I turned the modem/router's WiFi back on, only on 2.4 Ghz. This now runs simultaneously with the WiFi of my mesh network. I know that router after router is not recommended, but for my application it is not a problem. The modem/router 2.4Ghz is set to channel 1. The pumps also work on channel 1 in AP, so I am almost certain that they will also work on channel 1 in WiFi mode. I then added the MAC addresses of the pumps to the modem/router. Finally, and this is probably the cause of the connection problems, I set the modem/router's security protocol to WPA2-PSK. This gives me a connection to the pumps. I checked which protocol my mesh network was on and the default is WPA2-PSK, but I cannot connect to this. Since I cannot set the channels of the mesh, I suspect that the problem lies there somewhere. Still, thanks for thinking along.
I am wondering if it isn't something to do with the new app. I am having issues with mine and never had a problem until now. I even went as far as making a new account to see if that could be something. I am also wondering how you factory reset them because I haven't tried everything I could think of and nothing happens.
 

FreshSaltyGuy

Active Member
View Badges
Joined
Sep 28, 2022
Messages
416
Reaction score
223
Location
Central California
Rating - 0%
0   0   0
Hello everyone,

Hopefully there are some IT specialists here too. Already skimmed many forums (including this one) and tried all the tips. My apologies but this is going to be a long text.

I have 5 pumps all of which should be able to work with either wifi network or access point:
Jebao MDC-3500 booster pump
Jebao MDC-6000 booster pump
2x Jecod ALW-20 wave maker
Jebao MD-4.4 Doser pump

I bought the 2 booster pumps first. With this, the installation was still with the old app and was able to connect smoothly to my home network via my mobile phone (Samsung A52). In doing so, I used the wifi of my internet provider's modem/router.

Since this went so well, I bought the 2 wave makers as well as the doser pump.
However, with none of these pumps could I establish a connection to my ISP's modem/router. Tried further from the modem, tried near the modem, all to no avail. The direct access point (AP) between wave makers and my smartphone did succeed.

I then split the 2.4GHz and 5GHz signals in my modem's settings and disabled the 5GHz signal completely. Tried again to connect to the pump on my home network (again near and further away from the modem), however, to no avail.

I then installed the app on several android devices (Smartphone Partner, Smartphone eldest daughter, own tablet, tablet eldest daughter, tablet youngest daughter). On my youngest daughter's tablet, I was then able to connect to the wave makers via my wifi home network.

Since the wifi network was not so fantastically good anyway, I made the decision to build a mesh network. Note here that my provider or other providers in my country do not really give the option in free modem/router choice. A law to allow this has been passed and will apply on 01 November 2024.
What can be done is to place a 2 router after the provider's modem/router.
My choice is the TP-Link mesh ax3000 poe mesh wifi (deco x50-poe).
This mainly for the 6GHz and the poe (power over Ethernet).
The configuration of my network is as follows;
Modem router from the provider - Master mesh TP-link X50 - TP-Link switch with poe (model TL-SG2428P) - 3 x slave mesh TP-link X50 (each on their own port directly on the switch, so no through connections)
The router/modem, master TP-Link X50 and switch are on the 1st floor (ground floor) of the main building. The 3 slave mesh TP-Link X50 are on the 2nd floor (1st floor in Europe) of the main building, the 3rd floor (2nd floor in Europe) of the main building and the 2nd floor (1st floor in Europe) of the annex.
Disabled the wifi from the internet provider's Modem/router to avoid interference. This all works perfectly, I now have perfect wifi coverage everywhere in the house.

After reinstalling the new home network, tried again to connect to the wave makers on my wifi home network, again to no avail. Note here that the Jebao Aqua app had since been updated.

Disabled the 5GHz signal from the Mesh TP-Link X50, again with no result.

Also gave my Smartphone the update from Android 13 to 14 and tested again, with no result.

Put the wave makers in AP mode and checked if it was visible, using a wifi analyser (shows all available wifi networks in your area), which it was. To clarify, the pump in wifi mode is receiving and thus not visible as a wifi signal, the pump in AP mode is transmitting and thus visible as a wifi signal. The below image shows the channels of the Jeboa (0-3), my wifi network (4-8) and my smartphone (9-13). The channels of the TP-Link Mesh cannot be set. Also, the channels of the Jebao are these from which it transmits, I don't know if it can receive over the full channel width.
WIFI analyzer.jpeg



Took out my youngest daughter's tablet again (which did connect on the old network with the old app), it had also received the update Jeboa App by now. Tested to connect and this no longer works.

I then turned my partner's smartphone into an AP (in which case the smartphone turned into a router). Connected my smartphone to it and tried again to connect to the wave maker via the wifi network (of my partner's smartphone). This succeeded strangely enough.

Turned my Windows 10 Laptop into an AP and tried to connect again. At first, it failed to establish a wifi connection with the wave maker.
I had read somewhere that you need to allow location authorisation of the Jebao app, in the app settings of android. Allowed this and again tried to establish a wifi connection to the wave maker via my laptop's AP network. This worked again.

Then I had the idea, if I could run the app on my windows PC, which has a lan connection and a wifi connection to my home network, maybe I could establish a connection this way. Installed an Android emulator BleuStacks, then installed the Jeboa Aqua app on Bleustacks and then started the app. However, the app crashes during startup. No matter what I try, the app won't run. So again, no solution.

Using a USB-C Ethernet adapter, I made a direct LAN connection on the switch to my smartphone. To do this, however, I first had to disable the wifi and mobile network on my smartphone. Once this lan connection was established (tested using the browser, among others), I switched the smartphone's wifi back on. In the settings of the mesh TP-Link X50, checked whether a connection was visible via both wifi and LAN from my smartphone, which was the case. Restarted the Jebao Aqua app and tried to connect, strangely, the app indicated that no wifi network was detected and so I couldn't connect to a pump. So probably the smartphone prioritises a LAN connection over a wifi connection. The moment I physically disconnected the LAN connection, the wifi network was immediately visible in the app. I then tried, at the start of scanning for a pump, to immediately reconnect the lan connection. However again without result.

To check everything again, I tried connecting all 5 pumps to my home network again, with no result. In fact, I suddenly can't even make an AP connection with both feed pumps since installing the new app. I can make an ap wifi connection between my smartphone and the booster pumps, I can see the booster pumps' wifi signal with a wifi analyser but it doesn't manage to pair the pumps in the app. It keeps searching for the pumps.


As you can see, I have already tried a lot with limited IT knowledge.

These 5 pumps have cost a pretty penny and none of them has effective running hours in an aquarium yet. Had I known all this in advance I definitely would not have bought these. Hereby, if there are other people who would be interested in buying wifi pumps from Jeboa/Jecod, DON'T DO IT!

Meanwhile, I must try to carry on with this series and beg everyone if they don't know a solution.


Thanks in advance for the reactions,
Regards, JD
Did you ever find out how to get them connected. I have 2 pumps, and md-4.4 doser and all was working and after my provider briefly went down and I had to restart my Orbi I cannot get any to reconnect. Thanks
 

FreshSaltyGuy

Active Member
View Badges
Joined
Sep 28, 2022
Messages
416
Reaction score
223
Location
Central California
Rating - 0%
0   0   0
Ok after I read this again and posted I dug deeper and I got my 2 pumps and doser back on my Android phone app. This is what I did. Make sure your app on your Android has ALL permissions allowed for the app. I deleted the pump and doser in the app because it showed it but no lit up since it said Wi-Fi was not connected. So I thought deleting it made it good. However, it still didn't connect, so I got my wife's I phone 13 and connected it to our 2.4ghz network installed the Jebao Aqua app in the app store and made sure I allowed ALL permissions. When I logged in with my same email/pass the doser and pump were STILL showing up there but NOT connected to Wi-Fi again. So I deleted them AGAIN and then I closed the app completely on the iPhone and restarted the app and went to the "+" and added the doser first and then the pump and it all worked great. Then I went back to my Android phone, and did a refresh and they didn't show up, so I stopped the app and restarted it and now they show up and connected!!! Yay!! I hope this helps someone.
So remember just because it shows it has been removed from the cloud on one device doesn't mean it has truly been removed.
 

HOW LONG HAVE YOU BEEN REEFING? (TELL US YOUR BIGGEST MILESTONE IN THE COMMENTS!)

  • Less than 6 months

    Votes: 33 16.3%
  • 1 year

    Votes: 16 7.9%
  • 2-4 years

    Votes: 36 17.8%
  • 4-6 years

    Votes: 17 8.4%
  • 7-10 years

    Votes: 14 6.9%
  • 10-15 years

    Votes: 17 8.4%
  • 15-20 years

    Votes: 26 12.9%
  • Over 20 years

    Votes: 19 9.4%
  • Over 30 years

    Votes: 18 8.9%
  • Umm....Yeah, it's been a super long time. No comment.

    Votes: 4 2.0%
  • Other (Please explain!)

    Votes: 2 1.0%
Back
Top