MP40 noise

Top Shelf Aquatics

SPR1968

No, it wasn’t expensive dear....
View Badges
Joined
Feb 21, 2017
Messages
10,350
Reaction score
66,246
Location
Nottinghamshire England
I usually find it’s because it’s not seated correctly on the magnet, it will sometimes make like a vibrating/rumbling type of noise.

I move it around a little until it stops
 
OP
Nevets9333

Nevets9333

Active Member
View Badges
Joined
Aug 30, 2017
Messages
130
Reaction score
76
I usually find it’s because it’s not seated correctly on the magnet, it will sometimes make like a vibrating/rumbling type of noise.

I move it around a little until it stops
When you say sealed on the magnet, like the wetside and dryside are not lined up exactly?
 
Aquarium Specialty - dry goods & marine livestock

WIReefer

Taking it day by day
View Badges
Joined
May 10, 2017
Messages
1,760
Reaction score
4,816
Location
Wisconsin
What did you use to clean it? I used Vinegar on my Hydors and starting to think it warped it.
I use citric acid to clean all my equipment works very well and is safe, I have used vinegar to clean out old tanks.
 

SPR1968

No, it wasn’t expensive dear....
View Badges
Joined
Feb 21, 2017
Messages
10,350
Reaction score
66,246
Location
Nottinghamshire England
When you say sealed on the magnet, like the wetside and dryside are not lined up exactly?
Yes basically, just try moving the wet side around a little and see if that stops it.
 

Saltyreef

Valuable Member
View Badges
Joined
Nov 25, 2018
Messages
1,688
Reaction score
1,275
Location
Bay Area, Ca
Id also inspect the shaft on the wetside.
Might be cracked, exposing metal. And it would be noisy.

If all these fail, theres bearings that eventually wear out in the dryside. But i have a pump thats 10 yrs old still all original besides wetside.
 
OP
Nevets9333

Nevets9333

Active Member
View Badges
Joined
Aug 30, 2017
Messages
130
Reaction score
76
Id also inspect the shaft on the wetside.
Might be cracked, exposing metal. And it would be noisy.

If all these fail, theres bearings that eventually wear out in the dryside. But i have a pump thats 10 yrs old still all original besides wetside.

I bough this used. Is something missing?
20200625_160403.jpg


20200625_160356.jpg
 
OP
Nevets9333

Nevets9333

Active Member
View Badges
Joined
Aug 30, 2017
Messages
130
Reaction score
76
Looks ok to me
Next step unclip the 3 clips and pull the impeller and mag off shaft to inspect. Ceramic looks intact thus far.
Yes when I cleaned it that looked fine. This no the qd wet or dry side right? Maybe thats why?
 
OP
Nevets9333

Nevets9333

Active Member
View Badges
Joined
Aug 30, 2017
Messages
130
Reaction score
76
It turns out its loud even when not on with the wet side. Is this the bearing?

 
Best reef aquarium LED lighting

Saltyreef

Valuable Member
View Badges
Joined
Nov 25, 2018
Messages
1,688
Reaction score
1,275
Location
Bay Area, Ca
Yes. All modes. That video was on constant speed.

Where would I get a new bearing?
Youd have to DIY. Its technically not replaceable but theres threads around with good writeups.

Did my mp10 and it worked great.

Just google mp40 or mp10 bearing replacement.
Youll need to order the correct ones from ebay or another supplier.
 
OP
Nevets9333

Nevets9333

Active Member
View Badges
Joined
Aug 30, 2017
Messages
130
Reaction score
76
I replaced the bearings and it worked. These are the ones I used if anyone is interested.

1593476267722.png
 

Is there anything that grosses you out about saltwater aquariums?

  • Yes (tell us in the thread)

    Votes: 109 43.4%
  • No

    Votes: 139 55.4%
  • Other (please explain)

    Votes: 3 1.2%

Online statistics

Members online
2,426
Guests online
4,918
Total visitors
7,344
MAXSPECT
Top