RMA'd Two Pumps and a Light And No Word Back?

ImNemo

Active Member
View Badges
Joined
Sep 4, 2019
Messages
188
Reaction score
252
Location
Mississippi
Hi,
I have had to RMA two mp40's and a Gen 4 Radion XR30W. They were recieved on the 12th and so far I have recieved no communication? I know most people can afford to spare $1000 in pumps and a light for weeks but I would really appreciates some type of communication.

Here are the usps tracking numbers

Light

9114999944314467764298

MP40's

9114999944314467764311
 
OP
ImNemo

ImNemo

Active Member
View Badges
Joined
Sep 4, 2019
Messages
188
Reaction score
252
Location
Mississippi
Yeah, I did. They want $640 plus shipping to fix them. Told me they could find no problems with one of the mp40's. The light was less than 18 months old.

I've got a t5 fixture and a cheap koralia powerhead that has outlasted this junk.
 
Last edited:
OP
ImNemo

ImNemo

Active Member
View Badges
Joined
Sep 4, 2019
Messages
188
Reaction score
252
Location
Mississippi
Well I finally heard back after calling ecotech customer service. Looks like they have discovered water damage in the light and damage within the dry side of one powerhead. They have advised me that my warranty does not cover either. Then to make matters worse they are shipping everything back because I cannot pay them $875 immediately. Somehow I thought they would handle this with a little more professionalism.

Screenshot_20190926-182029_Gmail.jpg Screenshot_20190926-182151_Gmail.jpg Screenshot_20190926-182127_Gmail.jpg Screenshot_20190926-190034_Gmail.jpg Screenshot_20190926-182316_Gmail.jpg
 
OP
ImNemo

ImNemo

Active Member
View Badges
Joined
Sep 4, 2019
Messages
188
Reaction score
252
Location
Mississippi
so they are "unprofessional" because you don't like their policies that you agreed to? hmmm.....
The light has been mounted above my aquarium along with my other two. I find it hard to believe there was water damage to only one. The blue light only would work and when I would try and change the color the light would shut off. Also one of the MP40's will not connect to my reef link and I was told that it is working properly. Yes I already know that it works but that doesn't change the fact that I cannot sync it using the reeflink because it will not show up. It is what it is.
 
Last edited:

AZMSGT

Valuable Member
View Badges
Joined
May 6, 2019
Messages
1,080
Reaction score
1,449
Location
Surprise, AZ
I would have called them back and spoke to a manager. If you’re not happy with the level 1 customer service always elevate, elevate and elevate. Ask for proof of what they are saying water damage is.

Your call.. but I would still be fighting the issue.
 

adrianr514

Active Member
View Badges
Joined
Apr 14, 2019
Messages
350
Reaction score
281
I see nothing wrong or unprofessional in their response. Do you have homeowners or renters insurance that would cover the equipment? Or what about your credit cards? A lot of them come with extended warranties on devices bought with the cards.
 

What keeps you "driving forward" in this hobby?

  • Tank success

    Votes: 154 39.6%
  • Hobby Friendships

    Votes: 12 3.1%
  • Boredom

    Votes: 6 1.5%
  • Fish as your pets

    Votes: 97 24.9%
  • Can't quit now! Too much invested.

    Votes: 55 14.1%
  • I make money from the hobby

    Votes: 7 1.8%
  • Other (please post in the thread)

    Votes: 58 14.9%

Online statistics

Members online
1,949
Guests online
4,535
Total visitors
6,484
Battlecorals
Top