1. Demonic

    Demonic Love Change R2R Supporter Build Thread Contributor

    Joined:
    Nov 13, 2009
    Messages:
    845
    Likes Received:
    468
    Location:
    Minot, ND
    Anyone ever had one not light up. The power supply light is on but when I plug it into the light it pops and the green light on the power supply goes out. No lights on at all.
     

  2. Ohashimz

    Ohashimz Active Member R2R Supporter

    Joined:
    Jan 6, 2017
    Messages:
    390
    Likes Received:
    271
    Look like the fixture have something wrong its shorting the power supply and triggering its protection ckt. Or power supply have something wrong and it cannot supply enough current to the fixture. Either way I think you need professional help
    Make sure the DC connector side is not wet or something that its shorting when you plug in.
     
  3. Demonic

    Demonic Love Change R2R Supporter Build Thread Contributor

    Joined:
    Nov 13, 2009
    Messages:
    845
    Likes Received:
    468
    Location:
    Minot, ND
    I have looked over the circuitry and there is nothing obvious there. I dont see how it would be the power supply since the green light is on prior to plugging in.
     
  4. Ohashimz

    Ohashimz Active Member R2R Supporter

    Joined:
    Jan 6, 2017
    Messages:
    390
    Likes Received:
    271
    It possible. If the power supply have an issue that is triggered by current draw.
    Anyway, either way you need proffecional help. Sorry I cannot help here..
     
  5. Demonic

    Demonic Love Change R2R Supporter Build Thread Contributor

    Joined:
    Nov 13, 2009
    Messages:
    845
    Likes Received:
    468
    Location:
    Minot, ND
    Has anyone had this issue before? Bump up
     
Draft saved Draft deleted

Share This Page