Bluewave 7 Dual M80 Ballast Troubleshooting

Discussion in 'Aquarium Lighting By Dana Riddle' started by rc1626, Dec 3, 2017.

Tags:
  1. rc1626

    rc1626 Active Member

    Joined:
    Dec 30, 2016
    Messages:
    181
    Likes Received:
    62
    Location:
    Long Island, NY
    Sorry Grandis. Not sure what other pics you'd be looking for. Now that it's working I'm not going to be opening it up again unless it warrants it. What you have seen is pretty much it anyway.
     
    Stlouphil likes this.

  2. Stlouphil

    Stlouphil Member

    Joined:
    Jul 22, 2017
    Messages:
    26
    Likes Received:
    39
    Glad it was a simple fix. Any future problems, as I stated Hamilton has the ignitors and capasitors. It takes about 3 days to get them. Replacing either is certainly not brain surgery and you’ll be up and running in 10 minutes. Hopefully you will not ever need to change them out. But, then again this is a MH balast. Lol
     
  3. A. grandis

    A. grandis Valuable Member

    Joined:
    Feb 15, 2012
    Messages:
    1,817
    Likes Received:
    643
    Location:
    Honolulu, Hawaii
    I wanted to see pictures of the tank with the lights on. LOL!
    Grandis.
     
  4. rc1626

    rc1626 Active Member

    Joined:
    Dec 30, 2016
    Messages:
    181
    Likes Received:
    62
    Location:
    Long Island, NY
    You don't want to see my tank yet. It's all frags at this point. Encrusting and growing but still boring frags nonetheless.
     
  5. A. grandis

    A. grandis Valuable Member

    Joined:
    Feb 15, 2012
    Messages:
    1,817
    Likes Received:
    643
    Location:
    Honolulu, Hawaii
    No worries. You gonna have some nice colonies in no time...
    I'll wait...
    Grandis.
     
  6. A. grandis

    A. grandis Valuable Member

    Joined:
    Feb 15, 2012
    Messages:
    1,817
    Likes Received:
    643
    Location:
    Honolulu, Hawaii
    Just want to update this thread. I have now my Blue Wave 7 ballast almost as it was originally.
    Finally got a green lit switch that fits the ballast and the strain relief cord retainer.
    It was working as it was, but I wanted to make it look nice and to be able to use the switch, if needed.
    Here are some pictures:
    [​IMG] [​IMG]

    My new 48" Spectra with Radiums with the Blue Wave in action with the Vornado fan to blow out the heat:
    [​IMG]

    [​IMG]

    The Radium is much whiter with the M80s than with the Luxcore.
    It does make a big difference when we use the proper ballast with the bulb.

    It would be great to find the exact same green lit switch with the "weather protection" (or whatever they would call it) , but I wasn't able to find yet.
    If anyone here knows where I can order that switch from please post the link.
    Here is a picture of it:
    [​IMG]

    Thanks to all of you who tried to help me out!
     
Draft saved Draft deleted

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
Loading...