High Iron

Long Island Reefer

Active Member
Review score
+0 /0 /-0
View Badges
Joined
Apr 28, 2020
Messages
401
Reaction score
295
Review score
+0 /0 /-0
Hey all,

Having a rough time with my tank lately, things are closed and not really opening, found a few things wrong. Few mushrooms randomly melting, not sure if they were bad from where I bought them or my tank. Now my goni's are closed and no longer opening.

Found my nitrates kind of high, did a few WC and put chaeto back in my tank and they are progressively getting lower. started at like 16ppm to now 8-9 ppm.

I ordered an ICP test and received it back, everything seems in check except Iron, Silicon, and Iodine.
Iron is 8.284 µg/l, the setpoint on this should be 0, but doesn't tell me how high 8 is. Is this off the Chart high and immediate concern or is it like over the next few days try to figure out the source.

Silicon is 428 µg/l with a setpoint of 0-200
Iodine is 137 µg/l with a setpoint of 30-90-i can figure this one out as i was manually dosing 2 drops a week due to it being to low.

Seems my salinity is a little low and have been slowly increasing.32.5 on the apex which converts to 1.0245
orp-252
ph swings between 7.79-7.96 throught a 24 hour period
Temp 78.7
9.15 alk
545 cal
1237 mg

Reefer 250-2x AI Nero 5-1 cor 20-2x hydra 32.

installed a grounding probe 5 months ago because i was getting some stray voltage.

Any ideas are greatly appreciated.
 
Lazy's Coral House

Pistondog

2500 Club Member
Review score
+0 /0 /-0
View Badges
Joined
Jun 28, 2020
Messages
3,490
Reaction score
6,674
Review score
+0 /0 /-0
Nothing you mention would cause mushrooms to melt.
Phosphate?
Iron abundance and stray voltage might indicate a component, heater, powerhead etc. Is failing. Are you connected thru a gfci?
 
OP
Long Island Reefer

Long Island Reefer

Active Member
Review score
+0 /0 /-0
View Badges
Joined
Apr 28, 2020
Messages
401
Reaction score
295
Review score
+0 /0 /-0
Sorry, was a crazy weekend.
Phosphate is .07 according to hanna tester.
i am connected through a GFCI with a grounding plug in the sump.

Just another symptom, My Nem is going nuts all over the tank and stinging stuff-might be the reason for the mushroom melting-might have been stung.
 

Randy Holmes-Farley

Reef Chemist
Review score
+0 /0 /-0
View Badges
Joined
Sep 5, 2014
Messages
46,460
Reaction score
35,885
Review score
+0 /0 /-0
Location
Arlington, Massachusetts, United States
Chemi-pure.com - All-In-One Aquarium Filtration
Top