MP 40 issues need opinion/help

Discussion in 'EcoTech Marine' started by islander84, Jan 10, 2019.

  1. islander84

    islander84 Unregistered Member

    Joined:
    Feb 17, 2011
    Messages:
    903
    Likes Received:
    29
    Location:
    Clarksville TN
    I bought a used pair of MP40wqd back around the end of June and just now getting my tank setup..... One of them has a loud bearing chatter noise coming from the dryside and the other one acts like it wants to start then goes through the modes and drops wetside..... where can i send these to have checked out/repaired? Rough cost? Thanks in advance!
     
    Tags:

  2. slewrock1

    slewrock1 Active Member R2R Supporter

    Joined:
    Jul 29, 2018
    Messages:
    126
    Likes Received:
    96
    Do you have the dry side adapters on your dry sides that are appropriate for your glass thickness? They make a huge difference.
    Otherwise, I would suggest you contact Ecotech directly. They have the best support team in the game.
     
  3. MSB123

    MSB123 Someone out there put something smart here. R2R Supporter R2R Excellence Award R2R Secret Santa Santa Barbara Reef Co-Op Build Thread Contributor

    Joined:
    Aug 11, 2017
    Messages:
    2,350
    Likes Received:
    1,842
    Location:
    Santa Barbara, CA
    +1!
     
  4. islander84

    islander84 Unregistered Member

    Joined:
    Feb 17, 2011
    Messages:
    903
    Likes Received:
    29
    Location:
    Clarksville TN
    I got the one to start working and it seems ok now. The other one still chatters. Yes my glass is 1/2” and i only have the gasket between them no spacers
     
  5. Hemmdog

    Hemmdog Active Member R2R Supporter

    Joined:
    Dec 9, 2018
    Messages:
    293
    Likes Received:
    511
    Location:
    Mountain View, CA
    Take it off you don’t need it
     
Draft saved Draft deleted

Share This Page

Loading...