MP10 Ceramic Shaft Broken

cocolococo

New Member
View Badges
Joined
Sep 7, 2016
Messages
21
Reaction score
7
Review score
+0 /0 /-0
Just broke two of my MP10 Wetside Ceramic Shaft. I got both WES And WQD

WQD Broke first.

The other one i broke IT by swoping the rotary magnet into the WES And got stuck Half way And by the time i pull IT out the WES ceramic shaft broke again.

I think WES And WQD are not the same?

Do i have to replace the whole wetside?

Is there any replace or DIY i can Just repair the shaft?
IMG_20190202_151353.jpg
 

Highgrade

2500 Club Member
View Badges
Joined
Nov 19, 2014
Messages
2,884
Reaction score
2,436
Review score
+0 /0 /-0
Location
Arizona
You're better off swapping out the wetside for a new one. Maybe reach out to Ecotech to see if they sell the parts you need.
 

Lorenz725

Active Member
View Badges
Joined
Oct 5, 2018
Messages
104
Reaction score
187
Review score
+0 /0 /-0
Just had this happen not to long ago. They do not sell parts for this you have to buy a new wet side. If anyone comes up with a way to replace or fix the ceramic sleeve they would make some good money.
 

dragon99

2500 Club Member
View Badges
Joined
Jun 30, 2016
Messages
2,740
Reaction score
3,869
Review score
+0 /0 /-0
Location
Texas
The MP10 seems fragile. I bought a new wetside for mine because I broke the ceramic on the original, and chipped the new one within a month. It's still hanging on fortunately but I'm very careful with it now. Never had a problem with my 3 mp40s
 
OP
C

cocolococo

New Member
View Badges
Joined
Sep 7, 2016
Messages
21
Reaction score
7
Review score
+0 /0 /-0
Just had this happen not to long ago. They do not sell parts for this you have to buy a new wet side. If anyone comes up with a way to replace or fix the ceramic sleeve they would make some good money.

You are right, hope some people come up with long term solution, i ended up buying two new Wetside from ebay. LoL i hope these last longer than 2 year for this high initial money i paid.
 
OP
C

cocolococo

New Member
View Badges
Joined
Sep 7, 2016
Messages
21
Reaction score
7
Review score
+0 /0 /-0
The MP10 seems fragile. I bought a new wetside for mine because I broke the ceramic on the original, and chipped the new one within a month. It's still hanging on fortunately but I'm very careful with it now. Never had a problem with my 3 mp40s

I got 2 MP 40 WQD as well, those MP40 Ceramic shaft are way thicker than mp10 WQD.
 
OP
C

cocolococo

New Member
View Badges
Joined
Sep 7, 2016
Messages
21
Reaction score
7
Review score
+0 /0 /-0
The same thing happened to mine, which was actually pretty new.

My WQD just 2 months over the 12 months warranty period, I am pretty much out of luck. Even worst is I broke my WES the same part as i was trying to interchange the WQD Rotor to WES, it got stuck half way through the shaft and by the time I pull it out it damaged my wes ceramic shaft. LOL
 

Holy_makerel

Well-Known Member
View Badges
Joined
Sep 12, 2016
Messages
718
Reaction score
641
Review score
+0 /0 /-0
Location
Richland
I had one of mine break free and I used a tiny bit of superglue put into one side of the ceramic tube, made sure to put that side down first onto the shaft and let it cure. That was over a year ago and I haven't had an issue since. I figured if it didn't work I'd have to buy a new wetside anyway. If you do this just use a little drop of glue so it doesn't squish out and possibly affect function
 
OP
C

cocolococo

New Member
View Badges
Joined
Sep 7, 2016
Messages
21
Reaction score
7
Review score
+0 /0 /-0
I had one of mine break free and I used a tiny bit of superglue put into one side of the ceramic tube, made sure to put that side down first onto the shaft and let it cure. That was over a year ago and I haven't had an issue since. I figured if it didn't work I'd have to buy a new wetside anyway. If you do this just use a little drop of glue so it doesn't squish out and possibly affect function
They really should offer some parts for that ceramic parts. Mine one is way too late to just glue it, the tips are not that smooth.
 

reef-rc

Valuable Member
View Badges
Joined
Feb 5, 2017
Messages
1,023
Reaction score
1,075
Review score
+0 /0 /-0
My MP10WQD ceramic shaft just gave out just hours ago. Started with a funny sound coming from the pump when I took it apart I found out way.

Seems there is no shaft only replacement still?
 
OP
C

cocolococo

New Member
View Badges
Joined
Sep 7, 2016
Messages
21
Reaction score
7
Review score
+0 /0 /-0
My MP10WQD ceramic shaft just gave out just hours ago. Started with a funny sound coming from the pump when I took it apart I found out way.

Seems there is no shaft only replacement still?

I am afraid not. Just bought the whole wetside and keep the magnet and cover as spare lol.
 

erk

Valuable Member
View Badges
Joined
Mar 19, 2014
Messages
1,382
Reaction score
2,027
Review score
+0 /0 /-0
Location
DFW
My original MP10 wetside cracked a couple years after I bought it used. I finally replaced it earlier this year. The new wetside cracked maybe a week or so after I installed it. I still let it run with the cracked ceramic, but about 2 weeks ago it finally just seized up on me or something. The controller flashed green and red no matter what I did. I said the heck with it and tossed the wetside and won't be using an MP10 anymore. The two Tunze 6055's provide more than enough flow.
 

Mical

2500 Club Member
View Badges
Joined
Aug 7, 2017
Messages
3,626
Reaction score
6,063
Review score
+0 /0 /-0
Location
Montrose
Sorry to hear all the woes about MP10s. I have 4 of them going on 5 years old. I clean them every other month in 50/50 vinegar/RO solution then lube the shafts w/ vegetable glycerin. Have had zero issues outside of the occasional snail getting "soccer booted" by impeller.
 
OP
C

cocolococo

New Member
View Badges
Joined
Sep 7, 2016
Messages
21
Reaction score
7
Review score
+0 /0 /-0
Sorry to hear all the woes about MP10s. I have 4 of them going on 5 years old. I clean them every other month in 50/50 vinegar/RO solution then lube the shafts w/ vegetable glycerin. Have had zero issues outside of the occasional snail getting "soccer booted" by impeller.

I have both MP10 WQD AND MP40 WQD, but the shaft in MP40 is way more durable way thicker.
 

reef-rc

Valuable Member
View Badges
Joined
Feb 5, 2017
Messages
1,023
Reaction score
1,075
Review score
+0 /0 /-0
Sorry to hear all the woes about MP10s. I have 4 of them going on 5 years old. I clean them every other month in 50/50 vinegar/RO solution then lube the shafts w/ vegetable glycerin. Have had zero issues outside of the occasional snail getting "soccer booted" by impeller.

vegetable glycerin is reef safe?
 
OP
C

cocolococo

New Member
View Badges
Joined
Sep 7, 2016
Messages
21
Reaction score
7
Review score
+0 /0 /-0
Sorry to hear all the woes about MP10s. I have 4 of them going on 5 years old. I clean them every other month in 50/50 vinegar/RO solution then lube the shafts w/ vegetable glycerin. Have had zero issues outside of the occasional snail getting "soccer booted" by impeller.

I'll try this from now on, Thanks. Just normal vegetable glycerin from health supplement store?
 

PICK the Most Tested & Least Tested Parameters of your Tank (Pick 2)

  • Calcium (most)

    Votes: 41 6.5%
  • Alkalinity (most)

    Votes: 444 70.1%
  • Magnesium (most)

    Votes: 5 0.8%
  • Phosphate (most)

    Votes: 51 8.1%
  • PH (most)

    Votes: 65 10.3%
  • Nitrate (most)

    Votes: 60 9.5%
  • Nitrite (most)

    Votes: 3 0.5%
  • Ammonia (most)

    Votes: 14 2.2%
  • (least) Calcium

    Votes: 8 1.3%
  • (least) Alkalinity

    Votes: 4 0.6%
  • (least) Magnesium

    Votes: 52 8.2%
  • (least) Phosphate

    Votes: 10 1.6%
  • (least) PH

    Votes: 32 5.1%
  • (least) Nitrate

    Votes: 12 1.9%
  • (least) Nitrite

    Votes: 191 30.2%
  • (least) Ammonia

    Votes: 244 38.5%
Inkbird
Top