Protein skimmer trouble shooting

Tangina20

Active Member
View Badges
Joined
Jul 5, 2018
Messages
300
Reaction score
152
I recently cracked my tank and took my skimmer out and sat it in the garage for a few days and it isn’t working now. I’m not getting any bubbles and the skimmer is vibrating a lot more than usual. I soaked everything in vinegar and checked for clogs in the airline but still nothing. There are usually bubbles coming out of the blue piece I circled in the picture but there isn’t any now. I’ve also cleaned all of the water out of the airline silencer

522FC46C-D8BE-4F83-A5C7-3AB028EF1B39.jpeg
 

High ICP

Active Member
View Badges
Joined
Apr 4, 2019
Messages
302
Reaction score
250
I don’t remember bubbles coming out where you say they do. That’s the water intake.

Anyway, is it pulling water when turn it on? Or just not pulling air?

Take it off the skimmer and test it in a sink.

That whole piece comes off. Take it apart and clean it out. Might have worms castings inside.
 
OP
Tangina20

Tangina20

Active Member
View Badges
Joined
Jul 5, 2018
Messages
300
Reaction score
152
I don’t remember bubbles coming out where you say they do. That’s the water intake.

Anyway, is it pulling water when turn it on? Or just not pulling air?

Take it off the skimmer and test it in a sink.
Is it me....it looks like you have liquid in the muffler??? That could be your problem.
my last sentence said I got all of the water out and still didn’t help:(
 

Hillbillyreefer

Active Member
View Badges
Joined
Jan 12, 2019
Messages
112
Reaction score
127
Pull the air venturi out and check for salt deposits where the airline is attached.
 
Get Fish & Corals directly for the suppliers
OP
Tangina20

Tangina20

Active Member
View Badges
Joined
Jul 5, 2018
Messages
300
Reaction score
152
Pull the air venturi out and check for salt deposits where the airline is attached.
Just checked the Venturi with a paper clip and had no blockage. I tried blowing into the airline with the pump on and none of the bubbles were getting into the skimmer
 
OP
Tangina20

Tangina20

Active Member
View Badges
Joined
Jul 5, 2018
Messages
300
Reaction score
152
Just checked the Venturi with a paper clip and had no blockage. I tried blowing into the airline with the pump on and none of the bubbles were getting into the skimmer
When I cover the airline with my thumb the vibration and notice stops
 
OP
Tangina20

Tangina20

Active Member
View Badges
Joined
Jul 5, 2018
Messages
300
Reaction score
152
Is the needle wheel supposed to spin freely from the magnet? I have no movement when I try to spin it
 

High ICP

Active Member
View Badges
Joined
Apr 4, 2019
Messages
302
Reaction score
250
my last sentence said I got all of the water out and still didn’t help:(
You quote posted me?

Why?

I was just trying to help. It’s a crap $50 Chinese skimmer.

Buy a new one, I don’t care. Buy 10. You get what you pay for.

Reading your followup posts,,,,this must be a test right?
 
OP
Tangina20

Tangina20

Active Member
View Badges
Joined
Jul 5, 2018
Messages
300
Reaction score
152
You quote posted me?

Why?

I was just trying to help. It’s a crap $50 Chinese skimmer.

Buy a new one, I don’t care. Buy 10. You get what you pay for.

Reading your followup posts,,,,this must be a test right?
What is a quote post, not really understanding why you are offended lol...
 

High ICP

Active Member
View Badges
Joined
Apr 4, 2019
Messages
302
Reaction score
250
I am done taking your test

Can we block posters on this board?

Yup, we can put on ignore. Let’s see how this works.
 

homer1475

Figuring out the hobby one coral at a time
View Badges
Joined
Apr 24, 2018
Messages
916
Reaction score
1,198
Location
Way upstate NY
Wow a little touchy?

Anyways, its an (SCA 301 0r 302 I forget now)skimmer. Pull the entire thing apart and clean the motor block. The needle wheel should not spin without turning the magnet(they are spin together). Make sure the magnet and needle wheel move freely on the shaft inside the motor housing. You can even plug it in without the front piece off for a second to see if the motor is turning the magnet. Then pill the entire venturi(the blue piece attached to the motor front) and clean it completely. Reassemble and it should be good to go.

it could be the muffler? Try just pulling the tube off the bottom and see if it's pulling any air in.
 

homer1475

Figuring out the hobby one coral at a time
View Badges
Joined
Apr 24, 2018
Messages
916
Reaction score
1,198
Location
Way upstate NY
Forgot to add.....

When I had a 302 the motor would often knock a few seconds before it actually started up. Then it just stopped one day(motor block died). They are for, what it's worth cheap chinese skimmers with cheap motor blocks. I think you can buy a new one for just a few bucks.

49.99 on amazon, but you need the needle wheel.
https://www.amazon.com/Ph1100-Skimmer-Needle-Impeller-Sca-301/dp/B00HP0Z9ZY/ref=asc_df_B00HP0Z9ZY/?tag=hyprod-20&linkCode=df0&hvadid=241886436424&hvpos=1o1&hvnetw=g&hvrand=1833881638793956858&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9005245&hvtargid=pla-434050537342&psc=1
 
OP
Tangina20

Tangina20

Active Member
View Badges
Joined
Jul 5, 2018
Messages
300
Reaction score
152
I am done taking your test

Can we block posters on this board?

Yup, we can put on ignore. Let’s see how this works.
I was updating the thread of my findings, thanks for all of your advice!
 
OP
Tangina20

Tangina20

Active Member
View Badges
Joined
Jul 5, 2018
Messages
300
Reaction score
152
Forgot to add.....

When I had a 302 the motor would often knock a few seconds before it actually started up. Then it just stopped one day(motor block died). They are for, what it's worth cheap chinese skimmers with cheap motor blocks. I think you can buy a new one for just a few bucks.

49.99 on amazon, but you need the needle wheel.
https://www.amazon.com/Ph1100-Skimmer-Needle-Impeller-Sca-301/dp/B00HP0Z9ZY/ref=asc_df_B00HP0Z9ZY/?tag=hyprod-20&linkCode=df0&hvadid=241886436424&hvpos=1o1&hvnetw=g&hvrand=1833881638793956858&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9005245&hvtargid=pla-434050537342&psc=1
Thanks for all the help! I’ll give everything a try. I loved this skimmer and it worked really well but I think I messed up letting it sit for a few days out of water...
 

MPS

Active Member
View Badges
Joined
Apr 20, 2018
Messages
170
Reaction score
149
Location
Southern California
Don’t worry about those that are rude on this forum. There aren’t many and that person doesn’t belong here. This is a place to ask questions and get help. It’s not your fault that this person didn’t read your entire post.
I had similar troubles with a slimmer. It turned out that the needle wheel began to work its way off the shaft and was hitting the motor housing. That caused LOTS of noise, vibration and caused the motor to stall. If you can, you could check the motor shaft and housing for wear. Make sure the whee is properly seated if you find any wear marks.
I may be completely off base but that’s what happened to my E-Shopps skimmer.
Good luck.
 

Have you ever been accused of talking to much about your tank?

  • Yes (tell us about it)

    Votes: 172 54.1%
  • No

    Votes: 146 45.9%

Online statistics

Members online
1,659
Guests online
4,232
Total visitors
5,891
Lotus Reef
Top