help! new rodi unit

Discussion in 'Bulk Reef Supply' started by Iiismet, Oct 20, 2017.

  1. Iiismet

    Iiismet Member

    Joined:
    Nov 2, 2016
    Messages:
    20
    Likes Received:
    7
    i cant for the life of me get my new 150gpd 4 stage rodi unit to not leak after the second canister, ive tried pulling the line out and putting it back in how it was 5 times so far and am kind of frustrated, its probably a simple fix but i cant figure it out! any help would be appreciated, picture below of where its dripping
    [​IMG]
     
    Tags:

  2. sullyman

    sullyman Active Member

    Joined:
    Oct 25, 2006
    Messages:
    29
    Likes Received:
    3
    What are the red o-ring looking things on the end of the white elbow?
     
  3. WWIII

    WWIII Well-Known Member

    Joined:
    Jan 13, 2016
    Messages:
    402
    Likes Received:
    270
    Location:
    Louisville, KY
    Make sure it's pushed in as far as possible. If it still leaks, take it out ans recut it flush, then push back in tight. If it still leaks, it could be a bad fitting.
     
  4. Denisk

    Denisk Well-Known Member R2R Supporter Build Thread Contributor Partner Member 2018

    Joined:
    Dec 6, 2016
    Messages:
    517
    Likes Received:
    400
    Where exactly is it leaking from? If it’s between the elbow and the line, make sure that elbow isn’t cracked. If it’s between the elbow and the canister, it may because it needs to be tightened. When I got mine from BRS, I had a few leaks. I ended up using some white teflon sealant tape and I’ve had no issues since.
     
  5. Iiismet

    Iiismet Member

    Joined:
    Nov 2, 2016
    Messages:
    20
    Likes Received:
    7
    its leaking from the red ro hose i believe, the red "oring" is one of those little pins that keep the hose in, but its the only fitting with one of them on it
     
  6. Denisk

    Denisk Well-Known Member R2R Supporter Build Thread Contributor Partner Member 2018

    Joined:
    Dec 6, 2016
    Messages:
    517
    Likes Received:
    400
    That o ring maybe broken as usually don’t leak. I’d recommend reaching out to BRS. They’d probably send one out to you no problem.
     
  7. Iiismet

    Iiismet Member

    Joined:
    Nov 2, 2016
    Messages:
    20
    Likes Received:
    7
    sorry its not an o ring its one of these things,
    [​IMG]
     
  8. WWIII

    WWIII Well-Known Member

    Joined:
    Jan 13, 2016
    Messages:
    402
    Likes Received:
    270
    Location:
    Louisville, KY
    I think those are mainly a "safety" of sorts. I don't think it should leak even without that on there. Although that doesn't mean it should be left off. The fitting is either bad or the hose isn't cut straight or isn't fully seated. Brs will fix you up.
     
  9. Zack@BRS

    Zack@BRS Active Member R2R Supporter Gold Sponsor

    Joined:
    Oct 6, 2017
    Messages:
    28
    Likes Received:
    41
    @Iiismet Sorry to hear about the leak. This right here is what I would suggest initially. We do leak check all units before they leave the house, but sometimes shipping rigors can cause damage. Regardless, we have a lifetime warranty on the housings for reasons just like this, and you can feel free to email, call, or live-chat with our customer service and we'll get you fixed right up!
     
    nfrench2100 likes this.
  10. Iiismet

    Iiismet Member

    Joined:
    Nov 2, 2016
    Messages:
    20
    Likes Received:
    7
    i took it all apart today and recut the plastic tubing that was leaking and made about 15 gallons and it didnt leak, but i have the red clip off the line because i cant seem to get it to attach properly now.

    ill be making another 40 gallons tomorrow and if it does leak again ill contact your customer service

    thanks everyone for your help!
     
    WWIII likes this.
  11. danielh

    danielh Well-Known Member

    Joined:
    Jun 1, 2016
    Messages:
    46
    Likes Received:
    13
    duplicate
     
  12. danielh

    danielh Well-Known Member

    Joined:
    Jun 1, 2016
    Messages:
    46
    Likes Received:
    13
    My first BRS RODI I bought this year leaked at all of the red tubing. They sent me new tubing to replace it, thinking it was the tube being made out of spec, after I reconnected, re-cut and reconnected several times. All on recorded for them to make sure I wasn't doing something wrong.. In the mean time they just sent me a whole new unit. They were very responsive, understanding, apologetic and helpful.

    The new unit did well at first but it's leaking now too. Only a couple hundred gallons made. IDK what to do now. I noticed the new leak yesterday and I haven't let them know yet. Neither of my units had the rings on them.
     
  13. Bulk Reef Supply

    Bulk Reef Supply Well-Known Member R2R Supporter Gold Sponsor

    Joined:
    Jan 15, 2013
    Messages:
    269
    Likes Received:
    375
    Location:
    Minneapolis, MN
    Hey Daniel,

    I'm really sorry to hear you're still running into issues :( That's definitely not acceptable and I apologize for the frustration. Can you give our customer service team a call to help sort through this? You can reach them at 763-432-9691 and we are here until 7pm CST tonight.
     
  14. WWIII

    WWIII Well-Known Member

    Joined:
    Jan 13, 2016
    Messages:
    402
    Likes Received:
    270
    Location:
    Louisville, KY

    Do you know what your incoming water pressure is? Shouldn't matter as these units are rated for much higher anyways, just kinda curious. Hope they get it sorted for you! BRS sells a lot of these units I'm sure, so unfortunate you got 2 that are having this problem.
     
  15. danielh

    danielh Well-Known Member

    Joined:
    Jun 1, 2016
    Messages:
    46
    Likes Received:
    13
    Sure, BRS. I was waiting to make some more water.

    Yes. It's in the 50's. I've considered turning my house up so I can use the 150gpd water saver.
     
    Bulk Reef Supply likes this.
Draft saved Draft deleted

Share This Page

Loading...