Kamoer X1 Pro T

Ecotech Marine

Mrmiles

Community Member
View Badges
Joined
Oct 5, 2019
Messages
77
Reaction score
66
Took a while to get mine to connect but it's up and running now. Thanks for the tips on this thread
 

Servopkg

Active Member
View Badges
Joined
Mar 31, 2020
Messages
127
Reaction score
83
Wow... I was looking at these and it sounds difficult to setup. Good luck with your pumps. I waited until the versa was in stock at LFS. (early may).. ECM is ramping up production of them.
 
OP
S

Saltyanimals

Active Member
View Badges
Joined
Jun 4, 2016
Messages
437
Reaction score
148
Mine arrived today. That's about 5 weeks total since I placed the order, but I suspect that's on the higher side due to some delays.

I however had no problem setting up. Was up and running in maybe 20-30 mins. Plug is US plug so they anticipated it to be used in the US. There was a manual in the box with a QR code. I zapped it with my iphone and downloaded and installed the Kamoer Remote app. Simple to create an account. Had no problems connecting it to my home network (Asus Mesh) and was updating firmware shortly after. Firmware did seem to almost freeze at 99%, but I left it alone and eventually all was well. Prob 5-10mins for firmware upgrade. App and all interactions so far have been in English and I never had to change any language settings.

Probably one of the easier devices I had to set up lately. Did I just get lucky?
 
OP
S

Saltyanimals

Active Member
View Badges
Joined
Jun 4, 2016
Messages
437
Reaction score
148
Been running flawlessly since Monday and my CaRX pH seems to stay solid. Time will tell, but very promising.

Question for you guys that have one. Mine came with what I consider a cap or adapter over the X1 Pro T tube connectors. It wasn't obvious to me they were on there until it fell out when I was wrestling with trying to get my tubing into the connectors. Struggled with this for awhile thinking maybe it was my tube size. Tried softening with hot water, but eventually they fell out. Does anyone know what those are and if they're important and should be saved?

Also.. any concerns with the pump clogging with junk in the CaRX water where a prefilter may be necessary?

Great pump so far!
 
First Choice

NR53

New Member
View Badges
Joined
Nov 29, 2018
Messages
24
Reaction score
20
Question for you guys that have one. Mine came with what I consider a cap or adapter over the X1 Pro T tube connectors. It wasn't obvious to me they were on there until it fell out when I was wrestling with trying to get my tubing into the connectors. Struggled with this for awhile thinking maybe it was my tube size. Tried softening with hot water, but eventually they fell out. Does anyone know what those are and if they're important and should be saved?
The plastic piece inside the nut that looks like a ring with four prongs? That's a compression ring that needs to go on the tubing before you tighten down the nuts.
 
OP
S

Saltyanimals

Active Member
View Badges
Joined
Jun 4, 2016
Messages
437
Reaction score
148
The plastic piece inside the nut that looks like a ring with four prongs? That's a compression ring that needs to go on the tubing before you tighten down the nuts.

thank you. Glad I saved and asked. So far not leaking, but definitely will take the opportunity and out it in correctly with those compression rings.

anyone else notice the tube life countdown timer of 1000 hrs? That’s 41 days and we have to replace if it’s running continuously ? I know things wear and tear but seems too low.
 

What percentage of blue versus white lighting do you think makes the best coral growth combo?

  • All Blue

    Votes: 14 2.6%
  • Mostly Blue

    Votes: 338 62.4%
  • Even Balance

    Votes: 138 25.5%
  • Mostly White

    Votes: 42 7.7%
  • All White

    Votes: 1 0.2%
  • Other (please explain)

    Votes: 9 1.7%
SaltwaterAquarium.com
Top