Maxspect Gyre stopped working

DracoKat

Valuable Member
View Badges
Joined
May 12, 2015
Messages
2,514
Reaction score
2,135
Location
Lawnguyland, NY
I will have to call support, but I wanted to see if anyone has suggestions?

my gyre stopped working. no sounds, no vibrations nothing.

The controller still lights up, appears functioning. All plugs are in.

gave the gyre a good cleaning. Took it all apart and gave it a 50% Vinegar soak and scrubbing (24 hours in bath).

any other suggestions I can try before I call support?
 

rkpetersen

walked the sand with the crustaceans
View Badges
Joined
Sep 14, 2017
Messages
4,097
Reaction score
7,257
Location
Near Seattle
Which controller are you using? If the advanced one, you could try the second power connector. And of course try power cycling the controller at least once, if you haven't.

Otherwise it sounds like the motor itself may have failed.
 
OP
DracoKat

DracoKat

Valuable Member
View Badges
Joined
May 12, 2015
Messages
2,514
Reaction score
2,135
Location
Lawnguyland, NY
its not the newer controller. the gyre is about a year and half old, closer to 2.

I think the motor did fail.

If I just buy another pump without controller, It should work, right? To save a bit on cost?
 

rkpetersen

walked the sand with the crustaceans
View Badges
Joined
Sep 14, 2017
Messages
4,097
Reaction score
7,257
Location
Near Seattle
its not the newer controller. the gyre is about a year and half old, closer to 2.

I think the motor did fail.

If I just buy another pump without controller, It should work, right? To save a bit on cost?
Another of the same pump model should work with the old controller, assuming the problem is with the gyre pump itself.

Hey, I'm going to read your pico tank thread. Really getting the urge to do one myself. I'd like to find a nice vase, though, and an attractive 3 gallon clear glass vase is surprisingly hard to find. :)
 
Mega Meltdown After Sale

cracker

Valuable Member
View Badges
Joined
Dec 11, 2014
Messages
7,164
Reaction score
16,130
Location
north east Fl
Iv'e had probs with mine also. Last less a couple years & something comes up. Iv'e replace them both . I'd be happy to pay more if they were more sturdy.
 
Last edited:

jpas

Active Member
View Badges
Joined
Jan 19, 2018
Messages
384
Reaction score
312
Try to spin the motor by turning the propeller to see if the plastic bushing has worn out, you should be able to feel the resistance of the magnets.

My xf280 eats through bushings every 2-3 months.
 

OLDREEFER44

Well-Known Member
View Badges
Joined
May 31, 2016
Messages
797
Reaction score
1,041
Location
Machias Washington
My last one (of 4) gave up yesterday. Spent way too much on parts to keep them going so have given up. Similar issues with other Maxspect products so don't buy them anymore.
 

cracker

Valuable Member
View Badges
Joined
Dec 11, 2014
Messages
7,164
Reaction score
16,130
Location
north east Fl
I do like the wide flow they put out. They just need a better quality
 
OP
DracoKat

DracoKat

Valuable Member
View Badges
Joined
May 12, 2015
Messages
2,514
Reaction score
2,135
Location
Lawnguyland, NY
Try to spin the motor by turning the propeller to see if the plastic bushing has worn out, you should be able to feel the resistance of the magnets.

My xf280 eats through bushings every 2-3 months.
I disappeared to try that. the motor sputters. it's not consistent. Guess the motor's dead
 

Hemmdog

Valuable Member
View Badges
Joined
Dec 9, 2018
Messages
11,388
Reaction score
42,192
Location
Silicon Valley, CA
Reviving an old thread:
I was doing a water change tonight and unplugged my gyre advanced controller. When I plugged it back in after the water change the controller wouldn’t turn on and I heard what sounded like some electrical popping noises. I’ve unplugged it all, power cycled the controller, plugged it all back in, no luck getting the controller to show any sign of power or life. I don’t know what to do, it’s my main flow source in my 90 gal. Kinda worried over here.
the green light is illuminated on the gyres power brick, so I’m not sure if that means it’s the controller that is the issue or just the connection coming from the power supply, any advice is appreciated.
 

Hemmdog

Valuable Member
View Badges
Joined
Dec 9, 2018
Messages
11,388
Reaction score
42,192
Location
Silicon Valley, CA
Reviving an old thread:
I was doing a water change tonight and unplugged my gyre advanced controller. When I plugged it back in after the water change the controller wouldn’t turn on and I heard what sounded like some electrical popping noises. I’ve unplugged it all, power cycled the controller, plugged it all back in, no luck getting the controller to show any sign of power or life. I don’t know what to do, it’s my main flow source in my 90 gal. Kinda worried over here.
The green light is illuminated on the gyres power brick, so I’m not sure if that means it’s the controller that is the issue or just the connection coming from the power supply, any advice is appreciated.
#controlleradvisor #reefsquad
Any ideas squad? My coral is looking mad.
 

Crabs McJones

Mayor of Reef2Reef
View Badges
Joined
Jul 24, 2017
Messages
26,287
Reaction score
131,071
Location
Wisconsin
Almost sounds like a power surge shocked the controller, especially if you heard popping. Can you take the controller apart and see if the circuit board is fried? Is the controller doing anything? Flashing red or trouble codes or is it completely dead?
 

Hemmdog

Valuable Member
View Badges
Joined
Dec 9, 2018
Messages
11,388
Reaction score
42,192
Location
Silicon Valley, CA
Almost sounds like a power surge shocked the controller, especially if you heard popping. Can you take the controller apart and see if the circuit board is fried? Is the controller doing anything? Flashing red or trouble codes or is it completely dead?
I’ll see what I can do. Nothing happens with the controller as of now, no lights, nothing.
 

Hemmdog

Valuable Member
View Badges
Joined
Dec 9, 2018
Messages
11,388
Reaction score
42,192
Location
Silicon Valley, CA
I think it’s cooked... I ordered a new controller... 1 year warranty is so crappy, what the heck.
 

How do you run activated carbon on your reef tank?

  • Reactor

    Votes: 289 37.2%
  • Filter Sock

    Votes: 31 4.0%
  • Mesh Bag

    Votes: 344 44.3%
  • Other (please explain in the thread)

    Votes: 12 1.5%
  • I don't run Carbon

    Votes: 100 12.9%

Online statistics

Members online
585
Guests online
2,722
Total visitors
3,307
GHL Advanced Technology
Top