Radion xr30 G3 repair question

Don's tank

Community Member
View Badges
Joined
Jun 15, 2016
Messages
42
Reaction score
21
Review score
+0 /0 /-0
I have a Radion xr30 G3 that is not working properly ad was hoping someone might be able to help me troubleshoot it. The fan still works, but the lights will not come on. The only exception is if I unplug the light and then when I plug it in, the lights come on for about 2 seconds and then go off again. The buttons on the unit flash red and green. I've done a general cleaning and I've attached pictures. I would appreciate any suggestions as I'm trying to avoid sending it back to EcoTech for repair.

Thank you
20210618_130001[8888].jpg
20210618_130009[8889].jpg
20210618_130016[8890].jpg
 

_AV

Active Member
View Badges
Joined
Oct 3, 2019
Messages
320
Reaction score
309
Review score
+0 /0 /-0
I have yet to run into a Gen3 with these symptoms that doesn't need some type of board level repair on either the LED module or the main board. the reason you are seeing the lights come on for a quick second is because the main board is sensing a short somewhere and shuts the light down to prevent further damage. One of my repair article covers it in detail:



You can also check my video series or Radion repairs for some ideas:
Code:
https://www.youtube.com/playlist?list=PLzkkWvD2apYWaTNU-9moaeveH46YK0RkN

and this video in particular:

Sending the light this old to Ecotech won't do you any good as they are no longer servicing Gen3 of this type. I can likely fix it for you if you prefer.
 
Upvote 0
OP
D

Don's tank

Community Member
View Badges
Joined
Jun 15, 2016
Messages
42
Reaction score
21
Review score
+0 /0 /-0
I have yet to run into a Gen3 with these symptoms that doesn't need some type of board level repair on either the LED module or the main board. the reason you are seeing the lights come on for a quick second is because the main board is sensing a short somewhere and shuts the light down to prevent further damage. One of my repair article covers it in detail:



You can also check my video series or Radion repairs for some ideas:
Code:
https://www.youtube.com/playlist?list=PLzkkWvD2apYWaTNU-9moaeveH46YK0RkN

and this video in particular:

Sending the light this old to Ecotech won't do you any good as they are no longer servicing Gen3 of this type. I can likely fix it for you if you prefer.
Thank you very much. Ill check out your video series. But I'd also like to contact you directly about possibly having you repair it.

I am curious, based on the pictures, does anything jump out as looking damaged, or is it not magnified enough to tell.
 
Upvote 0

_AV

Active Member
View Badges
Joined
Oct 3, 2019
Messages
320
Reaction score
309
Review score
+0 /0 /-0
It's really hard to tell from the pictures. There's some corrosion on the mainboard, but most of the board components are on the other side and are not visible from this angle. Plus the LED module components are covered by the lens.
Feel free to pm me if you need any help.
 
Upvote 0

When is the last time you purchased cleanup crew critters?

  • Past few days

    Votes: 65 12.3%
  • Past few weeks

    Votes: 137 26.0%
  • Past few months

    Votes: 169 32.1%
  • Over a half a year

    Votes: 76 14.4%
  • Over a year ago

    Votes: 76 14.4%
  • Other (please explain)

    Votes: 4 0.8%
AFX
Top