Melia

HELP! My zoanthids aren’t doing well!

I bought zoanthids from the petstore, and they were doing okay but suddenly stopped. All my aquarium levels are normal, with nitrite running slightly high. I just turned on the current this morning to help, but my zoanthids won’t open all the way, and they’re growing algae, what should I do to help

HELP! My zoanthids aren’t doing well!
Melia, Nov 22, 2017
    • john472
      Take a very soft tooth brush and brush off the algae. Then move them to a shelf or rock an inch or two off the substrate. Third and final get some green phytoplankton and feed them when they open.
    There are no comments to display.
  • Category:
    Soft Coral Photos
    Uploaded By:
    Melia
    Date:
    Nov 22, 2017
    View Count:
    139
    Comment Count:
    1

    EXIF Data

    File Size:
    1.9 MB
    Mime Type:
    image/jpeg
    Width:
    4032px
    Height:
    3024px
    Aperture:
    f/2.2
    Make:
    Apple
    Model:
    iPhone 6s
    Date / Time:
    2017:11:16 17:57:54
    Exposure Time:
    1/30 sec
    ISO Speed Rating:
    ISO 50
    Focal Length:
    4.15 mm
     

    Note: EXIF data is stored on valid file types when a photo is uploaded. The photo may have been manipulated since upload (rotated, flipped, cropped etc).

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
Loading...