Help identify prob and solution for new zoa plz!

Discussion in 'Zoa Discussion (CLUB ZOA)' started by Mariners, Apr 21, 2017.

  1. Mariners

    Mariners Active Member

    Joined:
    Aug 22, 2013
    Messages:
    263
    Likes Received:
    102
    Hi Everyone,
    Need help w figuring out the problem w these zoas. I floated frag in bag to equalize temp, then dipped a few frags in coral rx. Rinse w tank water then placed new frags in qt tank. My other frags are doing great, but this one in the picture has mucous surrounding a few polyps almost like a cocoon. Plz help me w this issue and rescue my rainbow infusions. I also looked up zoa pox, but this doesnt quite match up does it.

    IMG_0734.JPG

    IMG_0733.JPG
     

  2. Jason mack

    Jason mack Monti madness R2R Supporter Reef Squad R2R Excellence Award Reef Tank 365 Build Thread Contributor

    Joined:
    Dec 3, 2016
    Messages:
    3,651
    Likes Received:
    8,614
    Location:
    Holland
    Maybe he just needs time too aclimate too Your tank .. Maybe put him in a slughtly shady area for now ...
     
  3. Mariners

    Mariners Active Member

    Joined:
    Aug 22, 2013
    Messages:
    263
    Likes Received:
    102
    Yeah i looked at another thread and they thought is was fungus and when u smelled it it smelled like rotten eggs so i cut away the polyps that had it then did a 4 part tank water and hydrogen peroxide dip for 2 min (also heard this takes care of hair algae by polyps). So now just waiting for it to heal fingers crossed.
     
    Jason mack likes this.
Draft saved Draft deleted

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
Loading...