MP40 cracked and magnet completely rusted

Discussion in 'EcoTech Marine' started by Mortie31, Oct 28, 2017.

  1. Mortie31

    Mortie31 Well-Known Member

    Joined:
    Apr 5, 2016
    Messages:
    175
    Likes Received:
    103
    Location:
    Uttoxeter. England
    My MP40 wet side has cracked and the magnets completely rusted... it is several years old and worked flawslessly, but still shouldn't fail like this. I have had a few ICP results showing high metals and couldn't see anything obvious, I changed cabinet hinges etc and eventually after a few months I decided to reinspect everything more closely, As I had lost a few SPS colonies, I really never expected to find so much damage and rust behind the rear plate... very unimpressed. If these wet sides have a finite lifespan we need to know as a part designed to specifically work underwater should not fail like this... IMG_0465.JPG IMG_0467.JPG
     

  2. 3mm3

    3mm3 Well-Known Member

    Joined:
    Dec 14, 2006
    Messages:
    861
    Likes Received:
    476
    Location:
    Cape Cod
    This was the Quiet Drive model right?
     
  3. Fishfinder

    Fishfinder Well-Known Member

    Joined:
    Mar 21, 2017
    Messages:
    944
    Likes Received:
    548
    Location:
    Melbourne, Florida
    doesnt look like a quiet drive
     
  4. Mortie31

    Mortie31 Well-Known Member

    Joined:
    Apr 5, 2016
    Messages:
    175
    Likes Received:
    103
    Location:
    Uttoxeter. England
    No it's not qd it's the es model
     
  5. 3mm3

    3mm3 Well-Known Member

    Joined:
    Dec 14, 2006
    Messages:
    861
    Likes Received:
    476
    Location:
    Cape Cod
    Thank you. I have both couldn't remember what each looked like but definitely will keep an eye on them. Will ecotech replace it?
     
  6. xionggotstyle

    xionggotstyle Active Member

    Joined:
    Jun 21, 2016
    Messages:
    35
    Likes Received:
    6
    You were running a damaged product. I'm pretty sure they wont cover it. Its like saying that you ran out of oil on your car but drove it anyways and now the motor blew and you want to use the warranty to replace the motor. Better to just order another wet side if you can afford it.
     
  7. Dayson

    Dayson Well-Known Member

    Joined:
    Aug 15, 2015
    Messages:
    477
    Likes Received:
    201
    Location:
    Memphis, TN
    I had this happen to me on my QD. Actually a pretty common problem. They replaced mine even though it was out of warranty.
     
  8. Macdaddynick1

    Macdaddynick1 Well-Known Member Build Thread Contributor

    Joined:
    May 20, 2014
    Messages:
    876
    Likes Received:
    759
    Location:
    Reseda, California
    How did you come up with the analogy ?
     
  9. Mortie31

    Mortie31 Well-Known Member

    Joined:
    Apr 5, 2016
    Messages:
    175
    Likes Received:
    103
    Location:
    Uttoxeter. England
    I don't want anything, I'm not after a replacement!!! It's 6 years old and was actually still running, was a bit noisy but was fine. Im annoyed because a premium product by a premium company should not fail like this. I'm posting this purely to warn others to inspect very carefully and to remove the end plate and check for hairline cracks... In my opinion any product designed to be underwater should have zero chance of rusting full stop, I've had Tunze magnets over 10 years old that are still fine...
     
    Lowell Lemon likes this.
  10. Daltrey

    Daltrey Well-Known Member

    Joined:
    Sep 17, 2017
    Messages:
    135
    Likes Received:
    119
    Location:
    Guntown, MS
    This is a common problem. There are posts all over the internet concerning it. Just google vortech rusting and look at all the pics. All the fanboys can praise it all they want but ecotech needs to do something about it. Btw I also run mp40’s but mainly for the safety factor as i have had cheap powerheads burn out in my tank.
     
    Mortie31 and Macdaddynick1 like this.
  11. BMW540

    BMW540 Well-Known Member

    Joined:
    Oct 14, 2010
    Messages:
    95
    Likes Received:
    109
    Location:
    Cary, NC
    I had the same issue and am pleased with how they are handling the situation.

    04C7E6C1-2325-436B-BEF0-AB932BDCC34D.jpeg
     
  12. madweazl

    madweazl Well-Known Member R2R Supporter Build Thread Contributor

    Joined:
    Sep 19, 2016
    Messages:
    687
    Likes Received:
    554
    Location:
    Virginia
    Eek, guess I'll take a look tomorrow.
     
  13. daelie

    daelie Well-Known Member Build Thread Contributor Partner Member 2018

    Joined:
    May 8, 2015
    Messages:
    270
    Likes Received:
    191
    Location:
    Working probaby
    Seems to be pretty common in Vortechs, not only that, the shafts are made from some tungsten alloy instead of something a little more premium like titanium which you might expect on a 350 dollar pump. You should really take your pumps out and give them a good clean monthly if you own Vortechs to catch issues like these early since they're clearly not going to increase the quality any time soon.
     
  14. Asif Iqbal

    Asif Iqbal New Member

    Joined:
    Sep 13, 2015
    Messages:
    3
    Likes Received:
    2
    I didnot have rusting but my wet side started jamming up with error code on controller. I bought a new wetside this time a quietdrive version.., very pleased lot quieter and works like a charm! Bought it on BRS
     
  15. tommyhere

    tommyhere Well-Known Member

    Joined:
    Jan 22, 2016
    Messages:
    655
    Likes Received:
    210
    Once again, I'll say this about a mp 40 rusting. What a disapointment!
    Why don't they fix this?
     
    will424 likes this.
  16. firefishalumacraft

    firefishalumacraft Active Member

    Joined:
    Oct 20, 2016
    Messages:
    37
    Likes Received:
    19
    I had this on my Mp40Wes I fig that out of 5 years of running them 24hrs a day 365 Ill take a 79$ pump. Parts wear out after time. I fig it this way, if your bought your car new and ran it for 24/365 from 0-max rpm your 50k car would be warn out with 43800hrs some people look at 5 year old cars as warn out.
     
  17. jumpman420

    jumpman420 Member

    Joined:
    Jan 31, 2012
    Messages:
    6
    Likes Received:
    1
    Location:
    Wisconsin
    Both of mine went down within 4 years. Haven't put them back online yet
     
  18. Asif Iqbal

    Asif Iqbal New Member

    Joined:
    Sep 13, 2015
    Messages:
    3
    Likes Received:
    2
    At the end of the day, it’s salt water we are talking about and eventually everything will corrode and go bad...
    Ofcourse it’s a choice to go with a 79 dollar pump or 75 dollar quiet drive wet side

    The dry side motor usually fine.. take care
     
    Water Dog and firefishalumacraft like this.
  19. Mortie31

    Mortie31 Well-Known Member

    Joined:
    Apr 5, 2016
    Messages:
    175
    Likes Received:
    103
    Location:
    Uttoxeter. England
    I agree about wear and tear if the motor had given up I wouldn't have minded, after this time,but not parts rusting, which are designed to be used underwater and especially that ecotech know of the problem and don't seem to be rectifying it... at best they should have a warning that parts may corrode and potentially pollute your tank over time... it's complete indifference by a profiteering company..
     
  20. Daltrey

    Daltrey Well-Known Member

    Joined:
    Sep 17, 2017
    Messages:
    135
    Likes Received:
    119
    Location:
    Guntown, MS
    Always the same replies. It's only a $75 wet side. No it's $1000's in coral and livestock not to mention years of time. So Ecotech if your reading this then step up and fix it!
     
    Mortie31 likes this.
Draft saved Draft deleted

Share This Page

Loading...