Red Sea 750xxl First tank need help please!

newreef1

Community Member
Review score
+0 /0 /-0
View Badges
Joined
Jul 14, 2021
Messages
38
Reaction score
10
Review score
+0 /0 /-0
Location
wellesley
Hello everyone, everyone here was great helping me start with the basics. I need your help again please!!! I have a Red Sea 750 XXL and I just filled it for the first time and while I think the sump may need another 5 or so gallons I started the return pump and the skimmer just to make sure it was working fine. When I first filled the tank with water and it started trickling down into the sump it did not come through the first chamber before the mesh filters rather it came from the return pump valve and leaked from the return pump ( I’m using a sicce as recommended pump) Then I filled water directly into the sumps first chamber and waited for it to flow into the other chambers, when the last chamber was filled to the automatic top off float I turned the pump and skimmer on, the pump immediately put the water in the tank and was out of water very quickly I think maybe the water is not coming from my flow pipes into the first chamber. PLEASE HELP!!!!!!
 
Last edited:
Aquarium Specialty - dry goods & marine livestock

jwilliams860

Well-Known Member
Review score
+0 /0 /-0
View Badges
Joined
Sep 22, 2010
Messages
662
Reaction score
488
Review score
+0 /0 /-0
Location
Charlotte, NC
If it's coming out of the return pump plumbing then it sounds like your return lines in the tank are to low possibly, so gravity is just puking the water through the return line first.

What size pump are you running? I'd it's draining the pump section fast then you need to dial it back, if it's not a DC pump you need a valve on the return side so you can restrict the flow.

You have to find the happy middle, enough water coming down and the same going back to the display.
 
AF
Top