Mp10 stop working

Discussion in 'General Equipment, Hardware, Filtration' started by Reef man 89, Sep 23, 2017.

  1. Reef man 89

    Reef man 89 Well-Known Member

    Joined:
    Oct 8, 2016
    Messages:
    1,178
    Likes Received:
    709
    My mp10 dryside fell off the glass and hit the floor. I set it on pulse mode and guess it was turned up to much to were it vibrated off the tank. Now on the control it is flashing threw all the colors and will not turn back on. I have tried to unplug and plug back in to no success. I don't know what to do. Can someone please help me out with what I should do. The pump is not even a year old and I am so upset.
     

  2. Reef man 89

    Reef man 89 Well-Known Member

    Joined:
    Oct 8, 2016
    Messages:
    1,178
    Likes Received:
    709
    This hasn't happened to anyone
     
  3. scurvy dawg

    scurvy dawg Well-Known Member

    Joined:
    Sep 24, 2016
    Messages:
    108
    Likes Received:
    92
    Can you contact Ecotech since it is still under warranty? I'd go buy a cheap power head at your LFS in the mean time and try working through ecotech. From what I hear, they have pretty good C.S.

    In the future, you should always hang your MP's with the cord facing up and then use a stick-on wire holder like they furnish with the pumps. This will prevent the dry side from falling all the way down to the floor. It has saved me twice.
     
  4. Bob3655

    Bob3655 Well-Known Member

    Joined:
    Sep 15, 2015
    Messages:
    49
    Likes Received:
    39
    Location:
    So Cal
    if the controller is cycling through all the colors, that's usually a good indicator that the controller is dead. I believe in the manual there's a chart in the back that shows the different error code lights cycling on the controller.
     
Draft saved Draft deleted

Share This Page

Loading...