Nero 3 RMA time?

Ecotech Marine

Clo

NO SELF CONTROL | IG: @CrescentReefer
View Badges
Marketplace Rating
Joined
Feb 8, 2021
Messages
548
Reaction score
1,355
Location
New Orleans
Hello,

woke up this morning to my Nero 3 not running. Cleaned it per the video on the website, then I noticed it’s not showing up in the app at all for connection.

I filled out the service form request, but I was wondering if anyone knew how long it takes for one of these to be serviced? I tried calling them for an estimate after I submitted my ticket but got the no one is here to take your call message.

All I have in my tank right now is some fish, invert, a hammer and a zoa. Do you think they could go a couple more days without a wave maker while waiting for delivery of a replacement? Or should I just run to LFS right now and buy one? I have a feeling I need to go ahead and get a power head if the repair takes longer than a week and a half, but wasn’t sure how well they would hold out with reduced flow for a couple hours or even just a day or two.

Thank you!
 
Top Shelf Aquatics

Y8ZC

Community Member
View Badges
Joined
Nov 25, 2019
Messages
67
Reaction score
40
If the help I receive from AI on my prime 16 hd having a melted lens is any measure of quickness, AI sent me a new one over night and they accidentally sent me lens for a hydra so the immediate sent me the prime lens overnighted as well. As for the hammer and the zoas I think they’ll be fine in the flow of your return. My zoas get almost no flow and they are fine I just use the turkey baster and blow them out on my water changes. Most euphyllia or whatever the new scientific name of hammers, frogspawn, octospawn, etc. tanks have low flow in them.

I hope that helps and good luck with the power head.
 
OP
Clo

Clo

NO SELF CONTROL | IG: @CrescentReefer
View Badges
Marketplace Rating
Joined
Feb 8, 2021
Messages
548
Reaction score
1,355
Location
New Orleans
If the help I receive from AI on my prime 16 hd having a melted lens is any measure of quickness, AI sent me a new one over night and they accidentally sent me lens for a hydra so the immediate sent me the prime lens overnighted as well. As for the hammer and the zoas I think they’ll be fine in the flow of your return. My zoas get almost no flow and they are fine I just use the turkey baster and blow them out on my water changes. Most euphyllia or whatever the new scientific name of hammers, frogspawn, octospawn, etc. tanks have low flow in them.

I hope that helps and good luck with the power head.
I ended up putting it back in the next day to try and test it again, and it started working again so not sure what happened. But if it messes up again, it'll definitely be taking a trip to AI :)
 

Have you ever had aquarium equipment damaged by livestock?

  • YES (tell us in the thread)

    Votes: 35 17.0%
  • NO

    Votes: 154 74.8%
  • Maybe now that you mention it

    Votes: 14 6.8%
  • Other (please explain)

    Votes: 3 1.5%
Motorcitycorals
Top