Wondering about the cloudiness

BRS

Danroo

Active Member
Review score
+0 /0 /-0
View Badges
Joined
Feb 22, 2021
Messages
265
Reaction score
184
Review score
+0 /0 /-0
Location
USA
first of all my parameters are

salinity: 1.022
Ammonia: 0
Nitrite: 0
Nitrates: 2
Phosphate: 0.03

bio load 5 fish in a 20 gallon with clean up crew of snails hermit, brittle star and a cleaner shrimp. Everyone seems to be doing pretty good.

Using a hang on back filter which I also changed from aqueon 30 -40 recently. Changed a filter cartridge a month ago ( 3 months old tank ) after it was cycled to reduce nitrates that were reaching 25ppm every week and had to do water changes to reduce it water was clear but not crystal. Recently bought the RODI unit. Using rodi water now from tap and seeing a good amount of coralline algae grow cause of it. Did only 2 water changes with RODI water.

back to the topic I have not fed my fish for 3 days thinking the water will clear up seeing no change and resumed back to my feeding schedule starting today. Before feeding checked my almost month old filter cartridge it’s still looked pretty covered in gunk

I did so many changes that I have no idea what might be the cause.

any help would be appreciated, I’m scratching my head cause of this

thank you.

image.jpg
 
OP
Danroo

Danroo

Active Member
Review score
+0 /0 /-0
View Badges
Joined
Feb 22, 2021
Messages
265
Reaction score
184
Review score
+0 /0 /-0
Location
USA
Sounds like a bacterial bloom. Should go away in a few days (week tops). Increase aeration, otherwise nothing to worry about.
I did saw a bacterial bloom before, I stopped feeding for 3 days and it went away. But at the time I had a gunk full of filter media this time the filter cartridge is new and the 3 days of not feeding didn’t do much. Hopefully it goes away by its own in the next week with normal feeding. If not I mate change the filter and add a skimmer.
 
Upvote 0
QT FISH
Top