ICP phosphate results

Discussion in 'Triton Applied Reef Bioscience' started by silvestrob, Nov 9, 2017.

Tags:
  1. silvestrob

    silvestrob Member

    Joined:
    Mar 29, 2017
    Messages:
    8
    Likes Received:
    0
    Hello,
    my last ICP test says my phosphate are too high - P 106 µg/l and PO4 0.32436 mg/, but all my home tests, made with Hanna HI 713, were zero. Reading the ICP help I've found this cause "No Phosphate in the system" that sound me little bit strange, could someone helps me to understand better phosphate matter?
    In the mean time I've provided to add new media to the system.
     
    Tags:

  2. Scott.h

    Scott.h Valuable Member Build Thread Contributor

    Joined:
    Feb 21, 2016
    Messages:
    1,422
    Likes Received:
    760
    Location:
    Clio Michigan
    What other test kit did you use other then Hannah?
     
  3. DesertReefBoy

    DesertReefBoy Member

    Joined:
    May 23, 2017
    Messages:
    74
    Likes Received:
    23
    I would try another test kit. I have heard of people getting pieces of food or something similar in a test tube when obtaining a sample of water. That food can then sit in the test tube for up to 10 days and cause false readings.
     
Draft saved Draft deleted

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
Loading...