RODI Unit Reading

AI Hydra

TheSeas

Well-Known Member
View Badges
Joined
Jan 24, 2021
Messages
524
Reaction score
738
Review score
+0 /0 /-0
Location
NJ
Hi quick question, I recently purchased a BRS 4 stage RODI unit. In viewing the TDS in and out I am reading 1 in and 1 out. This is after flushing the waste line, using for over 2hrs and checking the senor probes. Is this common or is there something wrong with the unit. I contacted BRS and they stated it is fine. I appreciate your thoughts.
 
Last edited:
RAP
OP
TheSeas

TheSeas

Well-Known Member
View Badges
Joined
Jan 24, 2021
Messages
524
Reaction score
738
Review score
+0 /0 /-0
Location
NJ
The probes are before and after. Something is off which is not making me feel comfortable trusting the readings.
 
Corals.com
AI Nero 5

PICK the Most Tested & Least Tested Parameters of your Tank (Pick 2)

  • Calcium (most)

    Votes: 46 6.4%
  • Alkalinity (most)

    Votes: 505 70.1%
  • Magnesium (most)

    Votes: 5 0.7%
  • Phosphate (most)

    Votes: 68 9.4%
  • PH (most)

    Votes: 68 9.4%
  • Nitrate (most)

    Votes: 69 9.6%
  • Nitrite (most)

    Votes: 4 0.6%
  • Ammonia (most)

    Votes: 19 2.6%
  • (least) Calcium

    Votes: 10 1.4%
  • (least) Alkalinity

    Votes: 4 0.6%
  • (least) Magnesium

    Votes: 68 9.4%
  • (least) Phosphate

    Votes: 14 1.9%
  • (least) PH

    Votes: 38 5.3%
  • (least) Nitrate

    Votes: 12 1.7%
  • (least) Nitrite

    Votes: 206 28.6%
  • (least) Ammonia

    Votes: 272 37.8%
Copepods
Top